What all happened in March so far

I realize I have been a wee bit silent on the blog (not counting my replies in the comments section). This was due to private issues that drained the desire for social interactions. Nevertheless there was quite a bit of activity on the Slackware packaging front.

So, what new stuff?

First of all: yesterday, Adobe released a security update for their Flash plugins for Mozilla-compatible (NPAPI) and Chromium-compatible (PPAPI) browsers. Check the version 29.0.0.113 installation status on http://get.adobe.com/flashplayer/about/. You are encouraged to upgrade.

Chromium browser was updated twice… last week I made the final release in the 64 series available and today (repositories have not been updated yet) I am updating again, to the 65 release. Version 65.0.3325.146 comes with a large list of 45 security fixes, read the release notes to get the gist. Unfortunately, this new release has cost me a full week of recompiles, day & night, all the time running into new compilation errors. It was not trivial to come up with a set of patches that eradicated all the compilation errors. I wrote a couple myself, reverted a chromium commit and borrowed from Gentoo – thanks as always for these guys’ code troubleshooting skills. The discussion on the Chromium Packagers list has given me some ideas for the next iteration of the SlackBuild script that may not require this much patching. But I am pushing this version to my repository anyway, even though I just spotted a newer version on the Google blog… released yesterday. Damn.

Pale Moon browser got an update to  27.8.1. Many improvements and fixes over the 27.7.x versions, check their release notes for the details. Despite the fact that the new Mozilla Firefox is much improved as well, and a lot speedier since Mozilla switched to the Quantum codebase, people may still prefer the older codebase of Firefox from which Pale Moon was forked.

LibreOffice 6.0.2 was released last week and I built packages for Slackware 14.2 as well as -current. Still the best office suite available. I should try to build the LibreOffice online version sometime…

When Slackware 14.2 was graced with an updated set of gcc packages in the “patches” section (gcc-5.5.0 with a series of patches related to retpoline countermeasures for the recent Meltdown/Spectre vulnerabilities) I took the opportunity not only to give the multilib repository for Slackware 14.2 a refresher to gcc-5.5.0_multilib, but I also updated the gcc5 package for slackware-current in my regular repository to that 5.5.0 release – including the retpoline patches. Remember, my gcc5 package for slackware-current contains just the C, C++ and Java compilers and has two purposes: first it re-introduces  the GCC Java compiler which was removed in gcc-7; and second, compiling Pale Moon on slackware-current can not be done with its gcc-7 compiler… you need this gcc5 package.

E-book lovers with a fondness for organizing their collection using open source software will find a new Calibre package in my repository. Calibre 3.x for Slackware 14.2 and -current depends on libxkbcommon, podofo, qt5, qt5-webkit and unrar, and for Slackware 14.2 two additional dependencies are libinput and libwacom. All of those can be obtained from my repository as well. If you are not in need of an e-book catalogue and library program, then Calibre still has its usefulness as it includes a versatile E-book reader and a powerful EPUB editor.

Last but not least: I released a new set of Plasma5 packages. The KDE-5_18.03 release of ‘ktown‘ for Slackware-current offers the latest KDE Frameworks (5.44.0), Plasma (5.12.3) and Applications (17.12.3). Read the README file for more details and for installation/upgrade instructions. If you are adventurous, check out the ‘testing‘ variant of the ktown repository as opposed to the ‘latest‘ variant. In ‘testing’ you will find Wayland support. Note that this is experimental (hence the ‘testing’ tag of course) and not fit for day-to-day production work. The ‘latest’ repository contains a stable and productive, complete, and fun to use, Plasma 5 desktop environment.
One thing I want to mention is that I have added the new Falkon browser to the applications-extra section. Falkon is the renamed Qupzilla browser, based on Qt5, and it is destined to be added to the core Applications (not sure when precisely, probably later this year) and it will take the place of the venerable Konqueror. If you are using slackpkg with the slackpkg+ extension, don’t forget to run “slackpkg install ktown” to get the new falkon package installed, because “slackpkg install-new” will not catch new packages in 3rd-party repositories like ‘ktown’.

I promise to get a new PLASMA5 variant of the Slackware Live ISO image out soon, containing all this new stuff! Stay tuned for more.

69 thoughts on “What all happened in March so far



  1. I was just trying to compile falkon from source code but since you beat me on time I thank and I’ll install your package. You’re always the best, thanks.


  2. I installed Libreoffice 6.02 and the oddity is that all the icons in Libreoffice Writer – and the other apps is…all the menu icons do not show up, there are placeholders for them but no colored icons. Ideas? This is on a fresh Slackware 14.2 install on a new machine : )




  3. I’m using -current with your latest plasma 5. The desktop session is not being saved. e.g: if i log out with some apps opened, when i log in again they won’t autostart. scripts put on autostart won’t work either. Thanks for the package.



  4. fabio – if you find out what causes it and I have to patch anything, let me know. Perhaps there’s already a bug report if the issue is not local to your computer…


  5. Pingback: Links 15/3/2018: Qt Creator 4.6 RC, Microsoft Openwashing | Techrights



  6. Owen, I think the ‘older’ desktop environments still need icons in /usr/share/pixmaps in case an application’s .desktop file does not contain the full path to the menu icon. XFCE suffers from that, I do not run KDE4 anymore so my assumption there was wrong (I thought the menu icons would be OK there).

    This is the patch that will fix this menu icon issue, the next released libreoffice packages should incorporate it: http://git.slackware.nl/asb/patch/?id=0044b86f2c86af243cd5016254cfbb0213ba903b – if you want a manual quick-fix, you can create the symbolic links to the .png files yourself and then run “update-desktop-database /usr/share/applications” to update the menu database.



  7. Thank you as always Eroc.

    The subset of Packages I need for 14.2 and -current all work as expected.

    — kjh


  8. About plasma 5 not saving sessions/settings. If someone come across the same problem. Just remove the .kde folder in your home after the upgrade, log ou and in again (or reboot). Maybe it can be added to the README instructions for installing/upgrading plasma 5, after installing and rebooting it’s necessary to invoke #xwmconfig command and select plasma from the list (at least for me using init 3)


  9. fabio – perhaps a solution is possible where you don’t have to delete the compiete .kde directory, but indeed it is a fast way to get rid of any KDE configuration.

    About xwmconfig, please check the README which has a section that goes like this:

    NOTE:
    If you had installed KDE 4 as your default desktop previously, the removal
    of KDE 4 packages will break the symbolic link ‘/etc/X11/xinit/xinitrc’.
    An attempt to run ‘startx’ in a console will fail with a black screen.
    After installing Plasma 5 for the first time, you need to run ‘xwmconfig’
    and select ‘xinitrc.plasma’ as your desktop session.



  10. @Eric and all:
    has anyone tested Plasma/Wayland on current NVIDIA drivers? For what I read around, it seems that something has slightly improved, even if the support is still not complete.

    Most likely I will have to test it myself on desktop pc with GTX 1060. In any case I can revert to standard X11 by just reinstalling the related packages, right?


  11. LoneStar I make the packages available but I have not used them myself for a while 😉
    It is very easy to switch back and forth between the two sets of packages. With slackpkg+ it’s the easiest because you just change ‘testing’ to ‘latest’ or vice-versa in the ‘ktown’ URL, run “slackpkg update ; slackpkg upgrade-all” and that’s it.
    Otherwise the README.testing file lists all the Wayland-related packages that are different from the regular repo, and it mentions whether they are original Slackware or else ‘ktown’ package modifications. So a couple of well-chosen “upgradepkg” commands will do it.


  12. hi Bob,
    Is there any way to change the transparency of menus in KDE5?

    KDE5 also seems to be making choices for me about the contrast of text to the background. The problem mostly goes away if I use a dark theme but there are problems with dark theme contrast as well. I tried reading some of the stuff in the Plasma 5 online docs but it wasnt very helpful and seemed to be somewhat out of date.




  13. When running kde5 ‘kwave’ I get the message

    MenuNode ‘Crop’: icon ‘crop’ not found !

    but anything else seems to work well


  14. Helios, I have the same and looking at the Google results, other distros see this as well. You could perhaps create a bug report at bugs.kde.org. I have no idea if the missing icon is an indication of missing functionality (I can not find a ‘crop’ function at all in the GUI).
    I can not help with this kind of low-level application programming issues…


  15. alienbob, I should have searched a little more. In fact the icon ‘crop’ is lost since at least 2012 in kde4 !


  16. Hi Eric,
    since you mentioned ebooks (and I remember an earlier post you wrote about that as well):
    I’ve suddenly encountered a mysterious issue. I regularly download epub files (bought or on loan from the local library) to my PC and then transfer them to my ebook reader (an old Bookeen Odyssey). It has worked flawlessly, but today the file manager (both caja and thunar) insisted on mounting the reader as read-only, making file transfer impossible. After unmounting and mounting via terminal I could copy the file.
    Have you encountered anything similar? Could any recent slackware package update have caused this?
    Best,
    KG


  17. Hey Eric,

    is it possible to run libreoffice-current on slackware-live-xfce-current?

    I’ve been trying the 32 bit versions, with the latest jre8, but I get crashes.
    after also adding dconf, I can get it to run, but only as root. as “live” user, it exits after showing the splash screen, without error…

    — lode


  18. OK, I’ll follow up on my own question, in case someone else runs into the same problem:
    I found that disabling the use of java in LibreOffice solved the problem.
    Then I dug a bit further and found that using Sun jre-1.6 works, but Oracle jre-1.8 and Oracle jre-1.7 don’t. (I haven’t tried OpenJDK)

    So, in the end I have a brand-new OS with the latest browser and office suite, running on my very old laptop 🙂

    cheers!


  19. KG Hammarlund, you mention caja, so possibly you are not running a ‘real’ Slackware? It’s part of the Mate desktop. It could be that a package upgrade causes this, most probably that could be caused if you are running Slackware-current, upgraded to the latest -current release and that broke something in Mate. The automounter feature is provided by the Desktop manager, while your manual umount/mount is basic functionality of Slackware itself.



  20. Hi again,
    I run your LiveSlak/MATE version (64bit, -current). However, MATE doesn’t seem to be the culprit since the same happens on my old netbook with a plain slackware (32bit) installed, also upgraded with the latest -current packages.
    And all automount options disabled on both systems…


  21. Thanks for the pointer on LibreOffice+OracleJRE.
    I don’t think I would have discovered that workaround.
    Maybe you could add a README.TXT in the download folder for LibreOffice-32bit ?


  22. It can be found through searching the internet… I try not to address functional issues in README files to individual packages, that’s what I use the blog for.


  23. Re: ebookreader
    I found two easy alternative options for transfering epub files Calibre and (under wine) ADE both works perfectly. And if I just attach the reader I can transfer files via the terminal. The problem thus starts when I open the reader in a file manager.
    Since there are workarounds it’s no big deal. Just frustrating not being able to understand what has happened.


  24. I use Calibre and ADE (in Wine) too, but I was under the impression that for Calibre to find the ereader, it had to be mounted first anyway? I have always had ereaders with wireless network access and use a COPS server (https://github.com/seblucas/cops) to make my Calibre library accessible to my ereader.

    I can offer no helpful hints about that mounting issue of yours, unfortunately.


  25. When I connect my ereader via USB I get a dialog box in the reader: “Do you want to transfer files? Yes/No”. If No, the reader doesn’t show up at all. If yes, it mounts, and obviously rw since I can add/delete files via Calibre or ADE. But for some reason the file managers identifies it as mounted read-only.
    Well, as said I can live with it since I have alternatives. And maybe a future upgrade of whatever package involved will fix it.



  26. The rollback of fontconfig-2.13.0 to 2.12.6 in -current should also be done for the compat-32 version. It seems to cause problems in steam for example.



  27. — Configuring the base system.
    rm: cannot remove ‘/mnt/slackwarelive/etc/localtime-copied-from’: No such file or directory
    *** ./make_slackware_live.sh FAILED at line 1224 ***

    the iso is not build



  28. On menu transparency –
    I filed a bug with KDE [bug 391985] and they responded rapidly and requested screenshots and other documentation regarding the problem of transparent menus. However, they finally declared it to be a packaging problem and offered no assistance with how to create a desktop theme with no transparency.
    “Given that it reproduces with a fresh user account, at this point it seems like a distro packaging issue. Please contact the Slackware folks or Alien Bob to further troubleshoot the issue.”

    I am just reporting what I found out. The “fresh user account” having problems –> packaging issue seems like a non-sequitur to me.


  29. Regnad Kcin – then I wonder why a Google search returns so many threads for non-Slackware distros where the transparency issue is brought up and the only solutions seem to be to hack the background SVG files and remove transparency there…


  30. Regnad Kcin, I looked at your screenshots in https://bugs.kde.org/show_bug.cgi?id=391985 and I must say, I do not recognize this issue. The menu text on my computer is black, and can be properly read even with the semi-transparent menu. Your screenshot on the other hand shows grey text which is nearly invisible against the transparent background. I understand that this is not acceptible for you, but it is definitely not a packaging issue. This looks like local to your computer. Perhaps it’s the graphics driver?


  31. I did consider the graphics driver but took no action. I tried a different monitor (easy to do) and that did not help. Motherboard has Intel graphics. I used to have a Nvidia graphics card until it died and took the motherboard down with it. I have other machines but none running plasma5 right now. I didnt buy into the notion that this is a packaging issue nor the “logic” of that decision. Indeed non-slackware users are complaining also. I may try a different graphics card but it is going to be some days before i can get to it as i am going in for some “minor surgery” tomorrow. minor surgery is when they cut on other people. when they are going to cut on me I consider it not quite so minor.



  32. This one is Intel Corporation HD Graphics 630 (rev 04) Kaby Lake. It looks like Intel released a new stack in Feb 2018 but I don’t know if -current is taking that in or not.
    I have no problem with any other aspects of the display. We have some graphics intense presentations on multiple monitors and those are not creating any problems.

    I found this note about Plasma5–
    [https://www.slant.co/versus/1121/1125/~kde-plasma-desktop_vs_cinnamon]
    “Difficult to turn off some transparency
    Some of the transparency settings for Plasma can only be removed by changing away from the standard theme altogether. A bit disappointing as so many other things are configurable to the deepest detail and transparency in the wrong place can make reading menu entries for example difficult at times.”

    Actually I cannot find any theme that seems to fix the transparency problem.


  33. Hi All, my LibreOffice 6.0.2 is now unable to open/run after “slackpkg upgrade -all” as at today 27th Mar, my local time.
    I uninstalled and reinstalled it, but still not the same problem.
    Not sure anyone also having the same problem.

    Before slackpkg upgrade -all, it was just fine.
    Thanks!

    I am running Slackware -current.








  34. Hi Alien.
    Today’s current update ships icu61, breaking LO (which is compiled against icu60). I tried a hack with simlinks, but it didn’t work… I’m afraid the package needs to be recompiled :/


  35. Fred,

    A lot needs to be recompiled if you are running -current. My Plasma 5 Desktop Environment stopped working too. Et cetera.
    It’s the Easter weekend, and I am not sure when I’ll get the time to recompile these big packages (at least qt5 and libreoffice need to be recompiled, possibly chromium as well).

    In the meantime, people that have not yet upgraded their -current to the April 1st update, should wait a bit for 3rd party repositories to receive recompiled packages.


  36. Re: icu61
    The dirty symlink trick worked at least partially for me, (MATE desktop) but PaleMoon, vlc3, and MuseScore2 (dependent on Qt5webkit) all broke. Chromium works, as does vlc2.


  37. Don’t worry Alien, you’re already doing a lot for the community. Using -current implies having to deal with that kind of surprises… Maybe it’s Patrick’s April fool 🙂
    Happy Easter!


  38. I have got Calc file / size about 500k -120 tables/ in Slackware’s LIbreOffice it takes about 45 second to end writing after editing.
    The Calc window is unresposible during this writing.

    Recently I tested Debian based distro MX 17.
    The same file writes for about 5 second in their LibreOffice Calc.

    There is no logs.
    I’we got no clue what cause that huge difference?
    In huge file mor than 1mb it takes writing forever.



  39. Thank you, Eric, for the upgrades that fixed all my issues caused by recent slackware-current upgrades. Didn’t even have to rebuild my MuseScore package. Sterling work as always!
    Hope you still managed to get some rest during the Easter holidays


  40. Rest… no. Unfortunately.
    This took me by surprise too, I had not spotted the icu4c update that had been sitting in the non-public tree for a day because I was too busy at work.
    I would not have been able to fix everything in time regardless.


  41. Thanks Eric

    I not run any distro but Slackware. Just try live MX /like liveSlack/ from usb stick in my work.
    Suprise was that the same file on the same machine and that huge difference.
    Impossible but true.

    Colleagues from my work checked file on Windows Libre and writes like in MX-17.
    Something is wrong.
    I’ll try to recompile package on my machine.
    Hope it helps.



  42. Thanks for response.

    I do not know where to upload this file once without a whole registration procedure for this one time only.

    BUt meantime I change Libreoffice to that from Slackbuild.org.
    Compile from Willy’s slackbuild from official Libre package and it works. No such long delay in writing after editing file.

    If you have enough big Calc file You can compare it yourself between your compilation and that from Slackbulds.org.



  43. Bob, thought you might like to hear the result of changing video card relative to transparency and greying in Plasma5. I got hold of a new NVIDIA based video card and even with Nouveau the blacks are back and the transparency is less irritating. I installed the 390.48 NVIDIA driver and things are better. I would prefer more contrasty text everywhere, but it is much more readable now. The intel graphics driver seems to be interpreting the blacks as much grayer than does Nvidia.


  44. Regnad Kcin, still it remains weird that my laptop, also using the Intel driver, shows proper black texts instead of the unreadable greys your screenshot showed.
    But I am glad your desktop is OK now.


Leave a Reply to LoneStar Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.