LibreOffice 6.2.7 packages available for Slackware 14.2

There was a recent update in my repository of LibreOffice packages, but that libreoffice-6.3.2 was just for slackware-current.

There’s a recent release in the LibreOffice 6.2 stable series as well (ok… five weeks ago, not that recent…), and so I decided to use my build box’s free weekend to come up with packages for LibreOffice 6.2.7.
This release has a security improvement over previous versions, in that it will popup a warning to the user if a document tries to run an embedded script (similar to existing warning mechanism for embedded macros).

As you may know, the Document Foundation advises the 6.2.x series for use in production environments while the 6.3.x series is targeted at technology enthousiasts. Precisely why I have 6.3.x in the repository for -current and 6.2.x will be available for users of our stable Slackware 14.2.

Note: I am no longer including support for KDE4. The “libreoffice-kde-integration” package is no longer available for the 6.2.x releases in my repository and you should “removepkg” the older version if you have that installed. The KDE4 support in LibreOffice 6 has been broken for a while and your Office applications will run great on KDE4 without that “KDE integration”. The LibreOffice UI will be based on GTK3 widgets instead and KDE4’s theming engine will make that its User Interface blends in properly.
For the libreoffice-6.3 series and onwards, I will again build ‘libreoffice-kde-integration’ sub-packages but then targeting Qt5 and KDE5. That works really well.

Enjoy! Eric

12 thoughts on “LibreOffice 6.2.7 packages available for Slackware 14.2

  1. Pingback: Links 14/10/2019: Linux 5.4 RC3, POCL 1.4, Python 3.8.0 | Techrights


  2. Not so sure about that “your Office applications will run great on KDE4 without that ‘KDE integration'” bit. After installing 6.2.7 it *mostly* worked, but none of the drop-down menus on the Calc ribbon would actually drop-down. No ability to change font or background color, borders, etc. I reverted back to 6.0.2 (with KDE Integration) and all ribbon drop-downs are back to working.

    I’m running Slackware64 14.2, KDE4 with all latest updates.



      1. My /etc/profile.d/libreoffice.sh (with 6.2.7) is:

        !/bin/sh
        # To force the use of a certain VCL UI interface, use one of these envvars.
        #export SAL_USE_VCLPLUGIN=gen
        #export SAL_USE_VCLPLUGIN=kde4
        #export SAL_USE_VCLPLUGIN=gtk3_kde5
        #export SAL_USE_VCLPLUGIN=kde5
        #export SAL_USE_VCLPLUGIN=qt5
        #export SAL_USE_VCLPLUGIN=gtk
        #export SAL_USE_VCLPLUGIN=gtk3

        Everything is commented. Odd that these drop-downs work for you. I don’t have access to another system at the moment, but will try to get that and check this on another machine ASAP.


  3. After upgrade from former version, no luck with KDE. I receive thei error: “Couldn’t exec startkde: No such file or directory”. Read the README, reinstalled twice, rebooted, nvidia uninstall, reboot, nvidia reinstall, still same error. Any idea Eric?


    1. Are you drunk today? The question has zero relevance to the topic above. FYI, yesterday’s post on this blog (the October update of KDE Plasma5) discusses this issue of yours at length and also has the solution.



  4. Eic, my apologize… Forgot my two last posts, confusely written with “links”.
    Now i’ve read the right section comments of the blog and solved the problem.
    Sorry again… :-(((

    HP


  5. I use scim for Chinese simplified (smart pinyin) input. scim doesn’t seem to like qt5 so I dont get any chinese input for libreoffice now unless i select one of the gtk alternatives such as export SAL_USE_VCLPLUGIN=gtk3. That does indeed work. I have used the “sogou” alternative input tool with Ubuntu but I dont like sogou or ubuntu much. I found some note that the providers of scim have been flummoxed by qt5 but I will be looking for an alternative.


    1. Hi, I looked at https://www.linuxquestions.org/questions/slackware-14/kde-plasma-5-can-not-input-chinese-4175651702/#post5983446 (a thread which you also contributed to) to find out whether fcitx would be a better alternative to scim, but since I do not use either, I can not really tell and have to rely on the people actually using CJK input methods.
      Configuring LibreOffice to use a GTK UI is indeed a workaround, but it will not benefit all the Plasma 5 applications. And the SCIM developer states that he is not interested in adding Qt5 support: https://github.com/scim-im/scim/issues/21#issuecomment-381536177



Leave a Reply to alienbob Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.