Libreoffice 3.4.0

As I already announced in my previous article, I have been building LibreOffice packages for Slackware 13.37 (I have been running beta versions on my own laptop for a while which I never released) and they are finally available for download now!

Check out this URL: http://slackware.com/~alien/slackbuilds/libreoffice/

Otherwise (and because they have bigger download speeds to offer), use one of the mirrors like:

and grab those packages (the mirrors may take a little while to get updated).

The release’s announcement page states that “The first release of the 3.4 series, LibreOffice 3.4.0, is targeted to community members and power users, and should not be implemented in a corporate environment“. That does not mean a lot to folk like us – we are the power users. Try it out, you can always revert to my 3.3.x packages. My stance on the “stable versions” is that I will keep compiling LibreOffice 3.3.x packages for a while, but on Slackware 13.1. That should keep a lot of people happy if they require a stable version of this office suite.

Have fun!
Eric

22 thoughts on “Libreoffice 3.4.0


  1. So, it appears that it’s back to using .libreoffice for storing settings, etc.? Is it going to remain there going forward?




  2. @ariarat –

    Because:

    (1) What I do is creating packages, and you get the SlackBuild scripts for free. The slackbuilds.org web site only gives you SlackBuild scripts

    (2) Building libreoffice from source is too complex. Look at that script! If a SBo admin has to do QUA testing on it, he has to wait 7 hours for the compilation and then has to check a lot of things to see if the result is OK.

    This is why I keep all my own scripts in my own repository. I have very different goals than slackbuilds.org .

    Eric


  3. @Matt:

    There was a patch in the old (no longer used for 3.4) “build” tarball which changes the application directory for Slackware from .libreoffice to .ooo3. I have no idea who added that patch, it’s one of the past OpenOffice developers/contributers.

    Going forward, this directory should remain “.libreoffice” and I will have to look at disabling that old patch when I build libreoffice 3.3.x packages for Slackware 13.1…

    Eric


  4. @Willy –

    My initial sync to slackware.com was aborted after I went to bed, because of a network disruption. So if you synced from slackware.com you should re-sync now.

    Cheers, Eric





  5. Just installed your package and I get:

    The application cannot be started.
    [/home/michael/.libreoffice/3/user/extensions/shared/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/registered_packages.db] Berkeley Db error (0): Db::open: Invalid argument

    when I launch from the cmd line. Any ideas?

    Michael E.


  6. @Michael

    Try creating a symlink to “/home/michael/.ooo” directory:
    cd /home/michael/.libreoffice/3
    ln -s ../../.ooo3/user/ user


  7. Thanks for the quick reply, David. I did ls -a and I don’t have a .ooo directory. Prior to attempting this install, I did have the _SBo version of libreoffice installed. I don’t know if that has any bearing on the issue. I have a .libreoffice directory with the ./3/user subdirectories. Also, my system is x86_64, and I’m running slackware current. Thanks.

    Michael


  8. @Michael

    Excuse me, I thought you have OpenOffice installed.
    I don’t know the “_SBo version of libreoffice” stores user information…
    If I was in your situation, I would try to uninstall version 3.4, reinstall previous version, then look for the directory of user preferences and save a copy of this folder.


  9. David, thanks for your suggestions. Looks like I needed to delete my old .libreoffice directory (or copy it to .libreoffice_OLD) and then install libreoffice 3.4, so that the new installation could create its own directory. Appears to be fixed now. Appreciate your work, AlienBob! Thanks.

    Michael


  10. Hi Eric, thanks for the new 3.4 packages. I’ve installed them but using Calc I’ve noticed it’s very instable: it crsshes with a simple copy-paste action. Back to the 3.3.2 and now nomore problems.

    Nicola


  11. Ouch!! sorry for the copy-messages … errors typing captcha codes, but I see the messages have been equally posted.

    Nicola



  12. Am I the only one or does anyone else feel the Horizontal scrollbar at the bottom in calc is unusable?


  13. Sam, if you’re using a mouse try to click the central button, or the wheel button, on the bar to move it. I’ve just tried it.

    Now working good the Libreoffice 3.4.0



  14. MICHAEL: thansk so much. After a security update I had the same problem iand it got resolved the way you just mentioned. Delete .libreoffice dir and re-install it again. It works like a charm.


Leave a Reply to solarfields Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.