Compiling libreoffice, a bumpy ride

A new version of LibreOffice was released last week: 3.3.1. This is the first release where divergence from the old OpenOffice.org may become apparent.

Of course I wanted to build Slackware packages for it but being audacious, I decided to make some expansions to the SlackBuild script in order to achieve the following:

  • include more extensions by default
  • include dictionaries for some of the major world languages (US and UK english, french, german, spanish, dutch)
  • add more language packs!

I just did not think it would cost me 6 days of work to get the bugger to compile correctly… I needed to hunt down several patches, and find out how to apply patches at all in the build phase of LibreOffice. At this moment I have the 64bit packages ready and installed on my desktop machine, and that runs smoothly… but the 32bit build keeps throwing errors at me. Go figure.

I think I finally found how to fix this, unfortunately it takes 5 hours of compiling in my virtual machine to experience the error… or not. Hence the large delay in producing working packages.

One side effect of fixing the build process is that the new package again wants to use ~/.ooo3 as the preferences directory, instead of using ~/.libreoffice like my previous version of the LibreOffice package.  People that get fed up with the alternating use of these two directories can just remove the ~/.ooo3 directory and instead create a symlink to ~/.libreoffice/3 in your homedirectory (or the other way round of course, depending on what directory you like more):

$ ln -sf .libreoffice/3 .ooo3

I do hope and anticipate that I can present a complete set of LibreOffice 3.3.1 packages for your Slackware powered computer tomorrow… keep your fingers crossed.

Cheers, Eric

7 thoughts on “Compiling libreoffice, a bumpy ride


  1. Thanks (as usual) for all your work!!!
    I’ll really appreciate if you could add Italian to included dictionaries….Thanks in advance


  2. Thank you very much Eric!
    I have two questions.
    1. After removing “~/.ooo3” and creating symlink with “ln -sf .libreoffice/3 .ooo3”, I was not able to start Libreoffice.
    I receive this error:

    [/home/david/.ooo3/user/extensions/bundle/extensions.db]
    Berkeley db error (0): Dbcursor::get: DB_RUNRECOVERY: Fatal error, run database recovery

    Then I deleted the new symlink and place a copy of “~/.ooo3”, and all works well.

    2. In your packages the icons of Libreoffice applications are the same of version 3.3. Instead, when I used rpm packages from TDF, the icons were new. Why?


  3. @David:

    Ah yes, I forgot to add the new LibreOffice menu icons… they are not (yet) installed by default.
    I have updated the libreoffice.SlackBuild script so that next update of my package will use the new icons.

    Eric


  4. @michelino:

    Sure, I have updated my private copy of the SlackBuild so that next time I create a package, an italian dictionary will be added.

    Eric


  5. Pingback: Alien Pastures » LibreOffice 3.3.1 packages


Leave a Reply to Ellendhel Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.