VLC 3.0.16 packages for Slackware 14.2 and -current

largeVLCI have uploaded packages for VLC 3.0.16. I have not been paying much attention to VideoLAN development in 2021, as I was busy enough with other stuff and my VLC player did everything it needed to. But it was time (after 11 months) to come with a new set of packages for Slackware.

Between the previous 3.0.7 and this 3.0.16 release I updated some of the vlc packages’ internal libraries too: bluray, dav1d, dvdnav, dvdread, dvdcss, ebml, libva, matroska, opus, pcre2, speexdsp, ssh2 and vpx. I also added patches to the internal ffmpeg that fix crashes in MPEG2 DXVA playback.

A note about dependencies for the new package:

My Slackware packages for VLC are mostly self-contained with all of the supporting libraries compiled into the package. This makes for a minimal dependency on external libraries/packages. But there are some caveats with the new release: most importantly, it has a Qt5 user interface.
While Slackware 14.2 contains a ‘qt4’ package, it does not contain ‘qt5’ and therefore, the vlc-3.x package introduces some new external dependencies, all related to the Qt5 GUI: SDL_sound, OpenAL, libxkbcommon, libinput, libwacom, qt5.
On Slackware -current (pre 15.0 now) no dependency packages are needed; everything the vlc package needs is present in Slackware-current.

A note on compiling:

When you want to compile VLC 3 yourself, be sure to install java8 and apache-ant or your build will fail.
If you are running Slackware 14.2 you will additionally need the following four packages (required to compile the ‘dav1d‘ decoder): meson, ninja, python3, python3-setuptools. You will also need a newer nasm than Slackware 14.2 provides.

Where to find the new VLC packages:

Rsync access is offered by the mirror server: rsync://slackware.nl/mirrors/people/alien/restricted_slackbuilds/vlc/ .

For BluRay support, read a previous article for hints about the aacs keys that you’ll need.

My usual warning about patents: versions that can not only DEcode but also ENcode AAC audio can be found in my alternative repository where I keep the packages containing code that might violate stupid US software patents.

18 thoughts on “VLC 3.0.16 packages for Slackware 14.2 and -current

  1. Thanks Eric! I really appreciate the packages you provide. While I’m certainly not a prolific poster at LQ, I miss your commentary and advice. You have saved my tail on more than a few occasions, even if it is just pointing out the obvious.





  2. Got a message during install stating, “Could not parse file “usr/share/applications/Trash.desktop” : invalid key name: URL[$e]
    Possibly missing a leading “/”?


    1. I have not seen that message here. There’s also no sign of a “Trash.desktop” anywhere on my computers, in the /var/log/packages/* or in the /var/log/scripts/* file content.
      Probably something you added to your computer during the installation of some software.


  3. Pingback: Links 4/12/2021: Gedit Plans and More | Techrights




  4. Eric, firstly, endless thanks for your continuing work for the Slackware community. A testament to the quality of your work is that this is the first time in at least 15 years of Slackware use I’ve had any issue you haven’t already fixed!

    The 14.2 package is somehow missing /usr/bin/qvlc, /usr/bin/svlc, and copying those files from the -current package gives the errors
    main interface error: no suitable interface module
    main libvlc error: interface “default” initialization failed

    So it looks like for whatever reason your 14.2 package did not configure the qt5 GUI.

    I started building it myself to identify the problem, but my 14.2 package successfully built with svlc, qvlc, and the qt5 GUI works fine. So I’m unfortunately not able to offer much more insight into why yours is missing these :/ (Mine didn’t build dav1d because the 14.2 box does not have the sufficiently new nasm but I really doubt that’s the cause.)


    1. Yeah, I see what happened.
      I had mistakenly uploaded an older, faulty, version of this package. The -current package is OK.
      I managed to grab the correct vlc-3.0.16 package for Slackware 14.2 from my VM and I am going to upload that.
      Look for the package with buildnumber “2alien”.




  5. Many thanks for the package. Unfortunately it gives segmentation fault on my 14.2 (64 bit).
    I tried with “strace” and the last successful line that I see is
    “open(“/lib64/libz.so.1″, O_RDONLY|O_CLOEXEC) = 3”

    Using gdb it seems that it crashes when accessing the plugins.

    I’ll stay with 3.0.8, which works fine.



      1. Yes it is up to date, but I cannot guarantee that I have not changed the version of some packages. Anyway I recompiled vlc 3.0.16 on my machine and now it works. Many thanks.



Leave a Reply to Jen Cancel reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.