July ’15 Security fixes for Adobe’s Flash web plugins (extra critical)

adobe_flash_8s600x600_2The recent hack of the “Hacking Team” -a company that makes money from creating spyware for repressive governments –  has uncovered evidence that they have been exploiting a yet unknown security hole which is present in all Adobe Flash players since version 7.  Obviously based on the  information obtained from the public dump of Hacking Team’s 400 GB Intranet data, there’s a Zero-Day exploit out there in the wild that is actively targeting computers (thanks mancha for the link). Adobe have released patched Flash player plugins today that fix this security hole and you are all urgently advised to update your flash player packages.

For your information: The updated Slackware package for chromium-pepperflash-plugin has version 18.0.0.204. The updated flashplayer-plugin has version 11.2.202.481. The Chromium plugin was taken from the Google Chrome 43.0.2357.132 RPM which was released yesterday. New packages for my own chromium package based on the sources of that same version are underway, expect those tomorrow.

Download locations for the Flash plugins:

If you are using the slackpkg+ extension for slackpkg, then you just run “slackpkg update && slackpkg update flash”. Alternatively, you can subscribe to my repository RSS feed to stay informed of any updates.

Eric

11 thoughts on “July ’15 Security fixes for Adobe’s Flash web plugins (extra critical)


  1. Am still without my morning coffee, so aren’t as sharp as I would be. 18.0.0.204 is the fixed flash, correct?


  2. Jen, 18.0.0.204 is the version of the Chromium PepperFlash plugin (PPAPI). The NPAPI plugin for Mozilla-compatible browsers is version 11.2.202.481. Just as stated in the article.



  3. Pingback: Links 9/7/2015: LinuxIT Sold, Alpine Linux 3.2.1 Released | Techrights

  4. still don’t understand all these Flash updates
    don’t get me wrong, i know it is all about security, but how is it possible that a single piece of software is so buggy to need a fix every now and then?


  5. I’m running flashplayer-plugin-11.2.202.481-x86_64-1alien, and a lot of websites are still telling me that there “This plugin has security vulnerabilities”. This is on a fresh install of -current.



  6. Oh, ok. I just read that they are continuing to find 0day exploits in flash, up to 3 as I have seen so far, and some are actually calling for flash to end.

    What does that mean for us FF/flash users?




Leave a Reply to Johann Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.