VLC 2.1 Rincewind about to enter the arena

For quite a long time now, I have been compiling VLC packages in the 2.0 series (nicknamed “Twoflower”). My standard way of working is to prepare tarballs with pre-compiled code for the internally used libraries (the “contribs” in VideoLAN terms – stuff like ffmpeg, matroska, dvdcss etcetera) and then leave those precompiled tarballs relatively unchanged while I update the VLC version between builds. That way I can kind of guarantee that the internal encoding and decoding capabilities do not break all of a sudden –Β  new bugs are usually easily tracked down to VLC bugs.

Also, compiling a new VLC package does not take long that way – I just “import” the contribs and link against the binary code. Remember, I have to create 4 VLC packages for every Slackware release: 32-bit and 64-bit packages, and for both architectures I create an “unrestricted” (in terms of distribution) version as well as a one containing the MP3 and AAC encoders, and the DeCSS library, all plagued by software patents.

Someone asked me via email if I could upgrade some of the internal libraries, and that was something I was not really looking forward to – updating the internals of the VLC package often results in compilation errors and hunting for patches to get everything to work nicely together again. But for a while, I had been eyeing the progress in the 2.1 branch of the VideoLAN git repository. The next release of VLC is nearing completion and a “2.1.0-pre3” tag has already been applied to the repository, indicating that the developers are getting serious about finalizing “VLC media player 2.1.0 Rincewind“.

So I set to the task of collecting new source tarballs and updating the vlc.SlackBuild script. Actually, the update went rather well. I used the newest versions of libraries like ffmpeg, fluidsynth, libass, libcdio, libdc1394, libdvbpsi, libebml, libmatroska, libva, opus, orc, schroedinger, vcdimager, vo-amrwbenc, and x264. My first attempt yesterday, uncovered a regression in saving the VLC advanced preferences (VLC would crash) but after some interaction with the developers in their IRC channel, the cause was found and a fix was quickly applied (thanks Edward Wang).

I now present you with the 20130819git snapshot build of the vlc-2.1 branch. In fact, the player reports a RC1 in its version information:

VLC media player 2.1.0-rc1 Rincewind (revision 7cbb328)

I was most pleased to see that the VAAPI (GPU hardware-assisted) video decoding of AVI files no longer crashes VLC (possibly caused by my update of the internal libva library to the latest release). Also, the preferences window finally is fully resizable. Oh, and the ProjectM visualization works again – that plugin was broken if you had a VLC installed on -current which had been compiled on Slackware 14.

Note that I built these packages only for slackware-current! If you want to try out VLC 2.1 on Slackware 14 you can use my sources and build script to create your own package. Depending on the time it takes for Slackware 14.1 to emerge versus the release of VLC 2.1.0, I may still decide to create packages for Slackware 14. However, this git snapshot is mainly used to test the code and get bugs resolved before the 2.1.0 release is finalized. Hence my choice for slackware-current which is what all you tinkerers should have running anyway πŸ˜‰

Where to find my new VLC packages:

Rsync acccess is offered by the mirror server: rsync://taper.alienbase.nl/mirrors/people/alien/restricted_slackbuilds/vlc/ .

My usual warning about patents: versions that can not only DEcode but also ENcode mp3 and aac audio can be found in my alternative repository where I keep the packages containing code that might violate stupid US software patents.

Have fun! Eric

And a “thank you” goes to…

… all of you who voted for my blog on FOSS Force. Actually, you Slackers pushed my blog all the way to top position in the second round. There is a third and final round which started today with a remaining 10 blog sites – can I ask you to please vote for me again? Much obliged!

 

 

17 thoughts on “VLC 2.1 Rincewind about to enter the arena


  1. Voting taken care of! I do hope you win! πŸ™‚
    Thanks for updating the VLC libraries and providing the git snapshot! Compiling the final release for Slackware 14.1 will probably be the way to go, as the release timing of each will surely be close. As a related matter, you could similarly compile LO 4.1 for Slackware 14.1 after it’s released, and compile the one remaining point release of LO 4.0 (due for release at the end of October) for Slackware 14.0. Just my two cents. πŸ˜‰


  2. And voted again!

    Thumbs up for this very fine blog.

    It helped me uncountable times. Because of this blog I am running kde 4.10.5 on an otherwise standard Slackware 14.0 32 bit system.

    Just great!

    Marcel Geijsberts







  3. Pingback: Vote for Alien Bob









Leave a Reply to Andry Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.