Valentine present for Slackers

Today is Valentine’s Day. A moment to give some extra attention to people that are dear to you.

In my case, that’s everyone who loves, uses, supports, advocates or develops Slackware Linux. For all of you, I uploaded “KDE-5_19.02” to the ‘ktown‘ repository. There’s some updates in there that might interest you, see below.
If you do not (want to) run or install Slackware-current, I will make sure that a new ISO of the Slackware Live Plasma5 Edition will be available around the weekend. That way, you can safely try it out without having to touch your hard drive.

As always, these packages are meant to be installed on a Slackware-current which has had its KDE4 removed first. These packages will not work on Slackware 14.2.

What’s new for February 2019

My February 2019 release of KDE Plasma5 for Slackware contains the KDE Frameworks 5.55.0, Plasma 5.15.0 and Applications 18.12.2. All this on top of Qt 5.12.1. Yes!

Deps:
This month, Qt 5.12.1 was introduced to the “deps” section of my ktown repository. This new Long Term Support (LTS) release of Qt5 is accompanied by the latest ‘libxkbcommon’, ‘sip’ and ‘PyQt5’ versions. The ‘qt5’ package update also mandated a recompile of the ‘qt5-webkit’ package.
Unfortunately I am not able to compile the latest (and final) PyQt 4.x release, and the same goes for the Qt4 support in QScintilla. So I stuck with Slackware’s ‘PyQt’ and dropped Qt4 support from ‘QScintilla’.
Other news? I added a base for speech support in KDE Plasma (and Slackware) with the “deps” packages ‘pcaudiolib’, ‘espeak-ng’, ‘pyxdg’, ‘dotconf’, ‘flite’, ‘speech-dispatcher’ and ‘qt5-speech’ (that’s the compile order).
The KDE packages that will pick up speech support are ‘kanagram’, ‘kmouth’, ‘knights’ (applications) ‘kpimtextedit’, ‘kdepim-runtime’ (kdepim) ‘ktp-text-ui’ (telepathy) and ‘knotifications’, ‘ktextwidgets’ (frameworks). Let me know if speech support is adding value to your Slackware desktop (running Plasma5 but also as an enhancement to Slackware itself). If it does not add value then Patrick can safely skip these new packages in case he decides to adopt Plasma5.
And finally, I added ‘libsass’ and ‘sassc’ packages as new dependencies for ‘breeze-gtk’.

Frameworks:
Frameworks 5.55.0 is an incremental stability release, see: https://www.kde.org/announcements/kde-frameworks-5.55.0.php

Plasma:
Plasma 5.15.0 is the first installment in the Plasma Desktop 5.15 release cycle, with a focus on User Interface and User Experience improvements. Integration with 3rd party graphics toolkits – think of GTK but also Firefox – has improved significantly. See https://www.kde.org/announcements/plasma-5.15.0.php

Applications;
Applications 18.12.2 is a stability and bugfix update for the 18.12 release cycle. See https://www.kde.org/announcements/announce-applications-18.12.2.php and if you want more detail about the 18.12 cycle you should also read https://www.kde.org/announcements/announce-applications-18.12.0.php .

Applications-extra:
In applications-extra I have upgraded ‘kmymoney’, and recompiled ‘krita’ with a patch to improve its compatibility with the new Qt 5.12.

Where to get it

Download the KDE-5_19.02 from the usual location at https://slackware.nl/alien-kde/current/latest/ . Check out the README file in the root of the repository for detailed installation or upgrade instructions.

I will upload a new Plasma5 Live ISO soon. You will find it in https://slackware.nl/slackware-live/latest/

Have fun! Eric

65 thoughts on “Valentine present for Slackers

  1. Actually, I *did* manage to compile PyQt 4.12.3, but only for 64bit, and only on my laptop, not in the clean VM… I do not know what makes the laptop configuration so special that the compile went through error-free. I would appreciate it (and so will Pat as he ran into the same issue) if someone finds a way to compile the latest PyQt4 against the latest sip on -current.





  2. Hi Erik, thanks for your hard work, I can tell that because I manage to build the KDE “before” you using your scripts. Was a bit pain in the ass. Well I would like to ask if you can, in the next time you build Qt, also build the documentation(make docs) and add it in the package, or maybe create a package for Qt Docs before the qt5.SlackBuilds clean the temp files. Thanks.


  3. Hi Gustavo,
    I will not add documentation to the Qt package. Slackware packages are kept small by omitting documentation and large ChangeLog files. I stick to that standard.


  4. Thanks a lot! I’m perfectly happy with the MATE DE so I have never installed Plasma, but the new Qt5 version comes in handy for other reasons.

    BTW, it seems as if the Qt5 upgrade means that the issue with the libvpx upgrade in -current last week is solved and that the workaround symlinking ln -s libvpx.so.6 libvpx.so.5, in /usr/lib64, helpfully suggested by Gérard Monpontet in an earlier thread, is no longer necessary.


  5. KG Hammarlund, I have uploaded copies of the new ktown packages qt5, qt5-webkit, libxkbcommon packages to my regular repository so that those versions are again in sync. That also solves the libvpx issue of course.







  6. Hi Eric.

    I upgraded my kde5, I have a strange issue.
    I cannot start any application from the start menu, but if I copy it to the desktop it starts from there OK.

    Hoping for a clue.

    Don


  7. Hi Don,
    There’s only three things that come to mind which you should do. Reboot after install, make sure that you installed all the *new* packages that got added this month, and creating &testing with a fresh new account that never logged into Plasma before.
    Otherwise I don’t really have a good advice. I never heard of such an issue before.


  8. Hello,
    2 of my installations are upgraded and working well. Thanks 🙂

    Sadly the Valentine’s day is my boss’ birthday lol.


  9. Hi Eric.

    I did / re did what you said, ended cleaning my home directory and started over.
    Everything worked until I changed the theme to Oxygen, from that point I could not start a program from the application launcher.

    I’m not great at decoding error messages, but it seem to be a permission issue involving root.

    I am running the default theme now and everything is great.

    Don


  10. Hi Don, great that you managed to find the root cause of your issue. I have heard before of issues when switching from Breeze to Oxygen theme. Perhaps good to open a bug report describing the issue and hoping for a fix.


  11. Thanks Eric,

    Seems this has already been reported as an incompatibility between oxygen 5.14.5 and qt5 5.12.1-1

    I will hope as I like that theme

    Don


  12. Hi Eric,
    While KDE seems to be running fine, I have an issue with System Settings. It will not start from the gui menu, but will start from konsole. I will copy what seems relevant:

    bash-5.0$ systemsettings5
    Icon theme “gnome” not found.
    Icon theme “crystalsvg” not found.
    Icon theme “gnome” not found.
    Icon theme “crystalsvg” not found.
    WARNING: viewBackgroundColor is deprecated, use backgroundColor with colorSet: Theme.View instead
    file:///usr/lib64/qt5/qml/QtQuick/Controls.2/org.kde.desktop/private/MobileTextActionsToolBar.qml:48: TypeError: Cannot read property ‘height’ of null
    file:///usr/lib64/qt5/qml/QtQuick/Controls.2/org.kde.desktop/private/MobileTextActionsToolBar.qml:37: TypeError: Cannot read property ‘width’ of null
    WARNING: viewBackgroundColor is deprecated, use backgroundColor with colorSet: Theme.View instead
    KActivities: Database connection: “kactivities_db_resources_140445506000832_readonly”
    query_only: QVariant(qlonglong, 1)
    journal_mode: QVariant(QString, “wal”)
    wal_autocheckpoint: QVariant(qlonglong, 100)
    synchronous: QVariant(qlonglong, 0)
    Nothing to load – the client id is empty
    Nothing to load – the client id is empty
    WARNING: viewBackgroundColor is deprecated, use backgroundColor with colorSet: Theme.View instead
    org.kde.kcoreaddons: Error loading plugin “kcm_icons” “The shared library was not found.”
    Plugin search paths are (“/usr/lib64/qt5/plugins”, “/usr/bin”)
    The environment variable QT_PLUGIN_PATH might be not correctly set
    Invalid Context= “status” line for icon theme: “/usr/share/icons/learning-to-fly/36×36/status/”
    Invalid Context= “status” line for icon theme: “/usr/share/icons/learning-to-fly/36×36/status/”
    WARNING: viewBackgroundColor is deprecated, use backgroundColor with colorSet: Theme.View instead
    Invalid Context= “status” line for icon theme: “/usr/share/icons/learning-to-fly/36×36/status/”
    Invalid Context= “status” line for icon theme: “/usr/share/icons/learning-to-fly/36×36/status/”
    Invalid Context= “status” line for icon theme: “/usr/share/icons/learning-to-fly/36×36/status/”
    Invalid Context= “status” line for icon theme: “/usr/share/icons/learning-to-fly/36×36/status/”
    Invalid Context= “status” line for icon theme: “/usr/share/icons/learning-to-fly/36×36/status/”
    Invalid Context= “status” line for icon theme: “/usr/share/icons/learning-to-fly/36×36/status/”
    Invalid Context= “status” line for icon theme: “/usr/share/icons/learning-to-fly/36×36/status/”
    Icon theme “gnome” not found.
    Icon theme “crystalsvg” not found.
    KActivitiesStats( 0x289e9f0 ) ResultModelPrivate::onResultScoreUpdated result added: “kcm:kcm_icons.desktop” score: 5.26018 last: 1550409498 first: 1540574330
    QNetworkReplyHttpImplPrivate::_q_startOperation was called more than once QUrl(“https://download.kde.org/ocs/providers.xml”)
    Rating cannot be superior to 100, fallback to 100.
    Rating cannot be superior to 100, fallback to 100.
    Rating cannot be superior to 100, fallback to 100.
    file:///usr/lib64/qt5/qml/QtQuick/Controls.2/org.kde.desktop/private/MobileTextActionsToolBar.qml:69: TypeError: Cannot read property ‘selectedText’ of null
    file:///usr/lib64/qt5/qml/QtQuick/Controls.2/org.kde.desktop/private/MobileTextActionsToolBar.qml:61: TypeError: Cannot read property ‘selectedText’ of null
    Closing SQL connection: “kactivities_db_resources_140445506000832_readonly”
    bash-5.0$

    I just completely reinstalled and install-new all of KDE, thinking I may have left something out. My next thought would be deleting .kde. Seen anything like this?


  13. Hi Mike,

    This is very similar to what happened to me, just curious what theme are you using. My issue started much the same way, the more I tried to fix it and change things the worse it got until nothing would work.

    When I changed the theme to breeze, everything worked OK

    Don



  14. Thanks for the tip Don! All seems well at the moment. I don’t like the breeze icons, but it accepted and works with the tango icon set. I really miss the noia theme and icons. Plus the Keramic theme…..


  15. After I changed the main theme to breeze, I changed every other selection to oxygen. Now the only difference that I can tell is I don’t have a K for the application launcher, but the three dots and right bracket instead




  16. Hi Eric,

    I saw you have the xdg-desktop-portal-kde package but there is no xdg-desktop-portal package.

    I compiled my own xdg-desktop-portal with –disable-pipewire –disable-geoclue

    I was then able to use the GTK_USE_PORTAL=1 to get the plasma file dialogs in firefox.

    The slackbuild seems to have pipewire as a dependency.

    Thanks!


  17. Oxygen theme seems to have been the cause of several small niggling problems with the system tray, desktop, and freezes of the clock. No such problems with breeze so far but looks strange…will customize. I used Nuvola icons and Keramik with KDE4 – were my favourites. But I like the speed of KDE5. All still ok with Plasma5.




  18. Hi Eric,

    Just FYI, as the problem is probably upstream. This is the first monthly upgrade of Plasma of yours that has given me anything to say besides, “Works great!”. I’m running Slackware64-current on bare metal and in a VMware Player VM. On metal, my Desktop icons move around a bit right after logging in, but things settle down and work great. But in the VM, I can only run KDE at 800×600 resolution. If I try to set it to a higher resolution, it just snaps back to 800×600. I’m running the stock huge kernel in the VM, and 4.20.10 on the desktop machine, and both Slackware’s are *current* -current. Last month’s Alien Plasma didn’t so this. In the VM, I’m able to run XFCE at 1280×1024, but not Plasma.

    Thanks for everything you do for the Slackware community, Eric. Best regards.


  19. I have Plasma 5 on two machines, my crappy OLD Tower and a newer Laptop – I have issues of sluggish, freezing performance on the newer Laptop, but it runs smooth and flawless on the old Tower – I can’t seem to trace what might be causing the issue. Could be anything at this point. Otherwise, I love it!


  20. Owen, does that new laptop have a Nvidia GPU inside? This month’s update of Plasma5 no longer functions on my desktop with Nvidia GPU and the nouveau driver. The desktop freezes as soon as anything (menu’s, popups) needs to be rendered.
    I had to install the NVIDIA binary blob, that one works perfectly. But I would have preferred the nouveau driver… maybe a OpenGL issue? The X session freezes but i can remotely login to the desktop and work without any problem as long as I stick to the terminal, But shutdown is no longer possible, I have to use the hardware reset.
    This is what nouveau writes to the kernel log:
    nouveau 0000:02:00.0: fifo: PBDMA0: 00040000 [PBENTRY] ch 6 [00ff207000 Xorg[1327]] subc 0 mthd 0000 data 00000000


  21. Richard, I run the latest Plasma5 packages in a QEMU VM in 1024*768 or higher with no problem at all. Your issue sounds like its cause is somewhere in VMWare (configuration or the program).



  22. Hi Eric, I bumped into the Nvidia GPU and the nouveau driver issue. I was scratching my head, because my other two machines were working great. I will revert Ktown to the january version on the desktop machine untill this gets sorted out.

    Thanks alot.


  23. Eric, I found a workaround in VMware. Instead of starting the Slackware VM in Full Screen mode, if I start it in Windowed mode and then switch to Full Screen, I can get 1280×1024 resolution. It doesn’t stick between restarts, but at least it’s useable. Because of my hardware (Intel Core 2 Quad CPU), I can’t run higher than VMware Player 12, so I can’t tell you if an upgrade would help. Thanks for pointing me in the right direction.


  24. Bob, I find that that although changing the theme to Breeze from Oxygen initially improved things for me, the problems with icons getting lost and confused in the task manager bar and the system tray is persisting. I will try to more acccurately define the problem and get screenshots and file a bug report. I am not sure exactly how the problem is developing or how to make it repeat or if it is sort of repeatable as in after i do a and b then c occurs.


  25. Wow, I’m so glad I finally decided to read this. Stupid me, I never think to look in the most obvious location.

    @AlienBob:

    I’m having the exact same issue as you with nouveau, but only on my desktop PC which has a Nvidia Geforce GTX 560 Ti.

    This is on a completely fresh install (well, slightly older -current image, updated using slackpkg, and then added multilib support with slackpkg+ and rebooted).

    Regardless of the FOSS driver I was using (nouveau or modesetting with nouveau backend), I would have the same freeze with no errors in my logs whatsoever.

    I tried launching kwin first, and then opening an xterm running ‘sleep 60 && init 1’ as root, and then would launch plasmashell in another xterm. Once the freeze occurred, I would eventually get to a single-user login (as expected).

    I also realized that it was not a full hard-lock as acpid was apparently still running; hitting the power button would eventually cause acpid to perform a software shutdown.

    Installing the proprietary nvidia driver (390-legacy, since my card is a bit older) did the trick. Just wish I’d read this first! I was about to perform a full reinstall, thinking I hit a corrupt package somewhere deep down in the toolchain!



  26. Tried to install AMD Driver for Radeon 8400 HD – got the following error:

    error: Detected X Server version ‘XServer 1.20.3_64a’ is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib:XServer 1.20.3_64a:none:4.19.23:)
    Installation will not proceed.

    I guess I require a newer version : )


  27. Hi Eric, I tried to build PyQt4-4.12.3 on current, 64bit, but make always failed with “…QtCore/sipQtCoreQTimer.cpp:723:1: error: cannot convert ‘std::nullptr_t’ to ‘int’ in initialization…”

    I used the suggestion in the AUR https://aur.archlinux.org/pkgbase/pyqt4/ to edit the sip.h files in /usr/include/python2.7 and python3.6m

    I changed both files FROM:

    /* C++11 and later. */
    #define SIP_NULLPTR nullptr
    #define SIP_OVERRIDE override

    TO:

    /* C++11 and later. */
    #define SIP_NULLPTR 0
    #define SIP_OVERRIDE

    Then the build worked fine. I don’t know whether this is a legit way to do it and it does not explain why you succeeded on your current installation.


  28. Alexander, interesting!
    I can not explain why my compile of PyQt4 on the laptop worked… but your edits seem sane, just don’t understand why they are needed.
    From https://embeddedartistry.com/blog/2017/2/28/migrating-from-c-to-c-null-vs-nullptr :

    nullptr is a new keyword introduced in C++11. nullptr is meant as a replacement to NULL. (…)
    The general rule of thumb that I recommend is that you should start using nullptr whenever you would have used NULL in the past.

    And this patch set is also interesting:
    http://python.6.x6.nabble.com/PATCH-v2-1-6-Add-SIP-NULLPTR-SIP-OVERRIDE-compatibility-macros-td5240894.html



  29. Good news. I have a patch for sip and a patch for QScintilla, which allows me to compile PyQt4 and also allows to compile the PyQt4 support in QScintilla, which failed previously.
    Updated packages will come soon, I only did the 64bit part so far. I also have to coordinate with Pat’s upcoming slackware-current update on which my new packages have a dependency.


  30. Eric, the article on embeddedartistry is an interesting read. So sip assumed that once you use C++11 the new nullptr keyword is used consequently throughout the whole sourcecode?! Great that it works.


  31. Hi Eric, today Pat updated Python 3 to 3.7x. I’d like to hear from you if it’s OK to do so with your Plasma5 setup before proceeding with the update. Thanks!


  32. Eduardo,
    I do not use the Plasma5 desktop so I don’t know if it will be affected by the Python upgrade – but I notice that there are no threads on LQ (yet) reporting issues.
    Of the programs I regularly use, only one refused to launch after today’s -current upgrade: DevedeNG. I rebuilt it using the SBo script and all is well.


  33. I notice that the libxkbcommon-0.8.3 package puts two .la files in /usr/lib64:
    libxkbcommon.la and libxkbcommon-x11.la

    IIRC Pat declared last year that .la files in that directory should be avoided?


  34. Pat did not ‘declare’ that… in Slackware, he removed all .la files. THird party packages that install .la files do not affect Slackware in any way. Other applications that are compiled against these packages may or may not be affected.
    But… good point. I had meant to look at file content, but forgot. Those .la files are not needed and a future iteration will get rid of them.





  35. hi alienbob, weird thing with the newest ktown, everything worked in previous build.
    two monitor setup, using newest nvidia driver. (slackbuilds.org sbo’s). But my second monitor is now just black screen.
    With ksplash breeze theme ‘frozen’ on it. Primary screen works.
    I sometimes get a ‘ksplash something’ has crashed.
    Just to test, I switched to fluxbox, and both monitors came up fine. So it has to be something in kde. Also tried to disable ksplash theme, same result.
    Just wondering if you have any idea what part of kde could be the problem, so i can submit a bug. No idea what part of kde is doing this, don’t even know what log file to look at.
    thank you for all the work you do for slackware.


  36. I have a Lenovo laptop running Slackware64-current and Plasma5, and at home I routinely connect it to an external monitor to get two screens with the desktop stretched across the two. Never any issue.
    But… I do not use the Nvidia drivers on that laptop.
    My desktop computer also runs Slackware64-current with Plasma5, and the Nvidia card inside is managed by the Nvidia binary blob. That desktop has one monitor, so I cannot tell what it would do with a second monitor.


  37. Here’s a jewel for all the folk afflicted by the trouble w libQt5Core.so.5 not parsing despite its clear presence in a system. This SHIT has maddened me since last December, forcing me to stick w Qt5.11.2 to keep a running desktop in Plasma or LXQt, but with the advent of 5.12, the old workaround no longer sufficed, forcing me to find a more serious solution. Thanks be to St. Isidore, I did so this evening. You can read of it here:

    https://superuser.com/questions/1347723/arch-on-wsl-libqt5core-so-5-not-found-despite-being-installed

    or just type the following in a root command prompt:

    strip –remove-section=.note.ABI-tag /usr/lib64/libQt5Core.so.5

    I strongly advise you to keep this little siolver bullet handy for folks, as I KNOW I’m not alone!

    Keep up the GREAT hacking Eric, and Much Obliged!


  38. Here\’s a jewel for all the folk afflicted by the trouble w libQt5Core.so.5 not parsing despite its clear presence in a system. This SHIT has maddened me since last December, forcing me to stick w Qt5.11.2 to keep a running desktop in Plasma or LXQt, but with the advent of 5.12, the old workaround no longer sufficed, forcing me to find a more serious solution. Thanks be to St. Isidore, I did so this evening. You can read of it here:

    https://superuser.com/questions/1347723/arch-on-wsl-libqt5core-so-5-not-found-despite-being-installed

    or just type the following in a root command prompt:

    strip –remove-section=.note.ABI-tag /usr/lib64/libQt5Core.so.5

    I strongly advise you to keep this little silver bullet handy for folks, as I KNOW I\’m not alone!

    Keep up the GREAT hacking Eric, and Much Obliged!



  39. Hi Janis,

    I already have KMymoney in the package set for Plasma5. I checked out some comparison articles mentnioning skrooge and kmymoney but could not be convinced to add yet another personal finance program.



  40. LoneStar, the caveat being that it requires you run a Wayland session. The X11 session is not supported.

    And this means, we again have to look at elogind or you people can perhaps kindly ask Eric Koegel to finish his initial work on making ConsoleKit2 work as a replacement for logind.
    I do realize that other software (like SDDM) will also have to be patched to recognize ConsoleKit2 sessions as a valid alternative to login1 sessions. No idea whether this path is viable. In any case KWin supports CK2.


  41. @Eric:
    oh, I wasn’t aware that the ConsoleKit2 support for replacing elogind is not finished. I assumed that it was fully functional after your initial tests some time ago.

    But, now reading your reply twice, does this imply that after this merge in KWin 5.16 the proprietary NVidia drivers will ONLY work on Wayland session and no longer work on X11? Because I was supposing that this would have added Wayland support while keeping X11 support as we’ve had it until now…



  42. Eric do you have a script that pulls the latest stables for all your deps, kede, extra etc etc… Man if you been doing this manually that is wild to believe. Any way good job.
    checkout plasma cool stuff



Leave a Reply to Poprocks Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.