Updates for multilib gcc and glibc packages

After a period of silence, Pat updated the Slackware ChangeLog.txt again!

Apart from the latest in stable KDE4 releases (4.5.5), you will find a new kernel. The choice for 2.6.35.10 was made because the 2.6.35 series has long-term support and Pat is probably trying to stabilize toward a new release. More on-topic for this article, there are new glibc (2.12.2) and gcc (4.5.2) packages. For those of you running a multilib-enhanced 64-bit Slackware this means you need an updated set of multilib packages,  which I already created for you.

Check out http://slackware.com/~alien/multilib/current/ which contains my multilib versions of the new gcc and glibc packages in Slackware-current.

For installation/upgrade instructions see the multilib README or even better, read my Wiki article at http://alien.slackbook.org/dokuwiki/doku.php?id=slackware:multilib .

You will also find a subdirectory “slackware64-compat32“. That directory contains all packages that are generated by the massconvert32.sh script. In other words, everything you need (along with my gcc/glibc and compat32-tools packages) to turn your Slackware64-current into a multilib system. The choice is yours: either you download and install/upgrade the packages in the “slackware-compat32” directory which I converted for you, or you run the “massconvert32.sh” script to convert these packages from the Slackware originals and install those.

Good luck! Eric

PS:

Fast mirror at http://taper.alienbase.nl/mirrors/people/alien/multilib/current/

Rsync access offered through rsync://taper.alienbase.nl/mirrors/people/alien/multilib/current/

10 thoughts on “Updates for multilib gcc and glibc packages

  1. thanks a lot Eric for these: I had upgraded to latest current this morning and was afraid I can’t play Enemy Territory when I’ll be back /home 🙂


  2. Hi Ponce

    I have the advantage that I am able to see and use Pat’s updates when they have not yet been published. That allows me to build the multilib packages in advance. In fact when you look at the timestamps on the packages you’ll notice that they are already several days old.

    I am usually asleep when Pat pushes his updates, and that causes a delay of a few hours between the public Slackware updates and my own updates…

    Eric


  3. Hello,

    I’ve followed the changes you made to the multilib and I integrated them to compat32pkg: more precisely to the file that describe the 32-bit compatibility layer (adding of aaa_elflibs, gdk-pixbuf2, libelf, sane).

    Regarding aaa_elflibs, I found it contains the library libgcc_s.so.1 (/usr/lib) which is also into the (multilib) version of gcc. As these versions are different, and given the installation/upgrade procedure of the multilib (the glibc and gcc first, then the 32-bit layer), installing of aaa_elflibs will imply the overwrite of libgcc_s.so.1 from gcc.

    Is aaa_elflibs should not receive more attention by convertpkg-compat32 when libgcc_s.so.1 is already installed ?

    Greetings.


  4. le me say that I haven’t felt any delays: you have been fast enough to let me play ET also this afternoon \o/

    luckily for me, we live in the same timezone 😀 (lol)








Leave a Reply to SeB Cancel reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.