Tag Archives: ripper

Handbrake 1.2.2 packages fix library mismatch in -current

handbrake_logoHandbrake in Slackware-current was broken after a libvpx upgrade. So I had to recompile. Instead I took the opportunity to compile the new release of HandBrake (1.2.2). Read the releasenotes for the 1.2.x series if you are interested. Most notable is that the team switched back from libav to ffmpeg 4.x as the core engine.

Always uncertain whether the GTK+-3 based GUI will compile. This time, I had to patch a function call out of the sourcecode that was introduced in a later version of GTK+3 than we have in Slackware 14.2. But that was relatively easy, all you will miss is a clickable link to the Handbrake homepage in the “About” box I think. Slackware-current is still uptodate as far as GTK+-3 is concerned.

Please use the comments section to share your feedback about the Slackware package and the use of the Handbrake binary. I did not test, one of the reasons being that I do not have a DVD reader. I remember people giving feedback about older releases of Handbrake where DVD ripping had issues.
Note that my ‘handbrake‘ package does not have any external dependencies – unlike the slackbuilds.org version.
Install and run, it’s that simple. Everything you need is compiled statically into the package. The ‘HandBrakeCLI‘ program is the command-line variant, whereas ‘ghb‘ is the GUI variant of HandBrake, also found in the “Multimedia” menu of your desktop environment.

Packages for Slackware 14.2 and -current with AAC audio encoding support can be obtained from my “restricted” repository:

The variant which does not support AAC audio encoding and therefore does not violate US software patents can be downloaded from the regular repository:

Eric