LibreOffice 7.4.1 for Slackware 15.0 and -current

LibreOffice Community Edition 7.4.1 was released today and I already have the packages in my repository for Slackware 15.0 and -current. The Document Foundation blog post has all the details, let me do a verbatim copy of the most striking features in the 7.4 releases:

GENERAL

  • Support for WebP images and EMZ/WMZ files
  • Help pages for the ScriptForge scripting library
  • Search field for the Extension Manager
  • Performance and compatibility improvements

WRITER

  • Better change tracking in the footnote area
  • Edited lists show original numbers in change tracking
  • New typographic settings for hyphenation

CALC

  • Support for 16,384 columns in spreadsheets
  • Extra functions in drop-down AutoSum widget
  • New menu item to search for sheet names

IMPRESS

  • New support for document themes

Note that I compile these packages on Slackware 15.0. If you install them on Slackware -current you will also need to download ‘icu4c-compat‘ and boost-compat from my repository and install them. They are two compatibility packages containing older versions of the icu4c and boost libraries, in particular the versions that are part of Slackware 15.0 but no longer part of -current.

Get libreoffice packages from my own Europe-based server: https://slackware.nl/people/alien/slackbuilds/libreoffice/ or my US-based server: https://us.slackware.nl/people/alien/slackbuilds/libreoffice/ ;or any mirror if you wait a day, for instance https://slackware.uk/people/alien/slackbuilds/libreoffice/ .
These servers all offer rsync access if you prefer that to http.

Enjoy – Eric

32 thoughts on “LibreOffice 7.4.1 for Slackware 15.0 and -current

  1. Thanks Eric !
    Is it just me and my KDE on Slackware64 15.0 or does libreoffice 7.4.1 startup minimized ?
    The only way I can access the App after startup is right-click the Icon on my Panel [Other Actions]->[Maximize]
    — kjh



    1. Thanks alienbob.
      I was afraid that was the case 🙁
      I’ll dig around in my KDE Configs and try to find the culprit.
      I know I’ve seen a Config like ‘open minimized’ somewhere …
      Thanks again for all that you do.
      — kjh
      p.s. once I do the ‘unminimize’ routine, LibreOffice 7.4.1 runs great !


      1. Found it.
        I had an ancient shell script wrapper which was doing: exec /usr/lib64/libreoffice/program/scalc –calc “$@”
        Removed the –calc arg and the wrapper-script works as expected now.
        To Test … scalc starts up minimized when I run: /usr/lib64/libreoffice/program/scalc –calc foo.xlsx # where foo.xlsx is an existing Excel File
        Mystery solved( I was getting away with an error before ).
        Thanks again Eric !
        — kjh


        1. Hey Konrad and Eric.

          I recently installed LibreOffice for the first time, so version 7.4.1 is my first experience with it (the usual GREAT job, Eric). I had the same problem Konrad mentioned in his original comment, ie, LibreOffice apps were opening minimized, with only a 16 x 66 pixel window in the upper left corner of my KDE desktop. I decided to go looking through the blurbs and comments for previous iterations of LibreOffice in this blog and, walla! I found Eric’s advice to try uncommenting entries in /etc/profile.d/libreoffice.sh, and succeeded with setting “SAL_USE_VCLPLUGIN=gtk3_kde5”. Everybody’s mileage may vary, of course, but it worked for me.


          1. Thanks Richard for bringing that GUI configuration hint out of the dust and into the open again. It will certainly benefit some other visitor of the blog.


          2. Richard —
            Heads Up !
            I mentioned your comment over in LQ.
            Users running LibreOffice built via the SBo LibreOffice.SlackBuild are experiencing tiny opening Windows too and referred them here.
            — kjh


          3. And I thought it was only we two. 😉 Hopefully others will profit.

            Thanks!


            Richard


          4. All —
            This issue has been discussed fairly frequently all around the net as well as on LQ and it seems to be ‘for real’
            There is a patch for LO 7.4.1.2 that reverts a fairly-recent set of changes that caused the Window Size Bug.
            LQ User marav attached the patch here: https://www.linuxquestions.org/questions/slackware-14/libreoffice-in-slackware-4175647812/page24.html#post6386191
            I’ve not checked for myself but LQ user chris.willing reported that these patches have already been applied to 7.4.2.3 ( I trust him — he maintains the LibreOffice SBo 🙂 )
            Anyhow, the issue appears to be OBE because LO 7.4.2.3 includes the patches.
            Just sayin 🙂
            — kjh



          5. I was trying to save my applause until you announced LO 7.4.2.3 but …
            I installed LO 7.4.2.3 on Slackware65 15.0 + Multilib this morning when I saw that is was mentioned in your ChangeLog.
            The ‘Start Minimized’ bug has been fixed for me.
            Thank you for all you do Eric !
            — kjh


          6. Greetings Konrad and Eric. Same results here. I let slackpkg overwrite /etc/profile.d/libreoffice.sh after downloading and upgrading to libreoffice-7.4.2-x86_64-1alien. After rebooting (big Slackware update today), Libroffice Calc was the first program I opened. It opens maximized as desired, and “kf5 (cairo+xcb)” is the default UI renderer. I’m going to try setting other UI renderers to see if I notice any improvements or changes, but apart from that, all is good here.

            Best regards to you both.





  2. Pingback: Links 15/09/2022: Libadwaita 1.2 and Godot 4.0 Reaches Beta | Techrights



  3. When I build 7.4.1 from sources, or use allien version or rebuild from rpm, I always get :
    libreoffice –writer %U
    Unspecified Application Error
    nothing in logs, do somebody know if libreoffice has any log of theese errors ?
    Thx



      1. I tryied, that libreoffice –safe-mode works, so I searched. My appologize, but it seems czech google didnt find relevant ansfers for first 3 pages.
        It work now, I really have
        lspci |grep VGA
        00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
        so :
        export MESA_LOADER_DRIVER_OVERRIDE=i965 in /etc/profile.d/libreoffice.sh
        works perfect

        Many thanks to you 🙂 Best work, best packages, best Replyes 😉


        1. Hi Foldy,

          I am glad you made it work for you. Internet search skills are valuable, whether you use Google or DuckDuckGo does not make a difference. Learning to use the right search phrase is worth your investment of time.
          When I search for “unspecified application error libreoffice slackware” I get a lot of hints and the first ones on that list are all giving you the answer I gave you.


          1. Yeah, I searched : unspecified application error slackware 15 libreoffice and really on first 4 pages no relevant solution.
            Live depends on details…
            Thx for your help


  4. Hee Eric,
    I know this is your blog and all, so I probably have no right to say this, but could we please try to be a little bit nicer? I know it’s frustrating when you spend so much time for the community, and then people can’t or aren’t willing to put some effort in searching for a solution before asking, but still.

    Regards, Marco


    1. In general I am a nice person and I will help you solve your trivial or complex problems if they are related to my stuff that you are using – this blog is full of examples of that.
      But it’s my blog indeed. I spend a lot of time on my stuff and I get *really* irritated by people who expect me to do their google search.
      I quit visiting LinuxQuestions.org and helping people there exactly for reasons like this.



  5. Hey Hello,’
    how should I fix this? create a soft link ro the lesser so filename ??

    $ libreoffice –writer
    javaldx: Could not find a Java Runtime Environment!
    Warning: failed to read path from javaldx
    /usr/lib64/libreoffice/program/soffice.bin: error while loading shared libraries: libicui18n.so.69: cannot open shared object file: No such file or directory
    userx@slackdog.pen:~/Downloads/linbraoffice15
    $ ls /usr/lib64/libicui18n.so*
    /usr/lib64/libicui18n.so /usr/lib64/libicui18n.so.71.1
    /usr/lib64/libicui18n.so.71



  6. Hi Eric,
    I installed libre-office but draw doesn’t work. And i saw you don’t speak about draw in your description of libre-office above.
    So is that normal ?
    Thanks so much for your great work,
    Best regards,
    Bérenger


    1. Apparently there were no “striking features” in the 7.4 release of Draw.
      The application works for me by the way, I can’t advise anything helpful about a simple statement “draw doesn’t work”.


    2. Do you get any error messages when you execute “libreoffice –draw” in a terminal? (except for “javaldx: Could not find a Java Runtime Environment!
      Warning: failed to read path from javaldx” with should not prevent Draw from running).


  7. No i apologize, it wasn’t really java. Actually i downloaded libre-office from slackbuilds.org and i thought it was the same packets as Eric’s one.
    Newbie’s error, sorry. But it works now with the Eric’s package.
    Thanks a lot 🙂


Leave a Reply to Konrad J Hambrick Cancel reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.