Java update: openjdk 7u75 available

icedtea A new release of IcedTea  is available. Version 2.5.4 of the “Java build framework” will create OpenJDK 7 “Update 75 Build 13” (resulting in a Slackware package openjdk-7u75_b13).

The release announcement can be found on the distro-pkg-dev mailing list. It has a long long list of improvements and bugfixes – probably caused by the large hiatus between this and the previous release.

A list of  CVE’s is associated with the new release. Here is the skinny – all security fixes mentioned in the post:

  - S8046656: Update protocol support
  - S8047125, CVE-2015-0395: (ref) More phantom object references
  - S8047130: Fewer escapes from escape analysis
  - S8048035, CVE-2015-0400: Ensure proper proxy protocols
  - S8049253: Better GC validation
  - S8050807, CVE-2015-0383: Better performing performance data handling
  - S8054367, CVE-2015-0412: More references for endpoints
  - S8055304, CVE-2015-0407: More boxing for DirectoryComboBoxModel
  - S8055309, CVE-2015-0408: RMI needs better transportation considerations
  - S8055479: TLAB stability
  - S8055489, CVE-2014-6585: Better substitution formats
  - S8056264, CVE-2014-6587: Multicast support improvements
  - S8056276, CVE-2014-6591: Fontmanager feature improvements
  - S8057555, CVE-2014-6593: Less cryptic cipher suite management
  - S8058982, CVE-2014-6601: Better verification of an exceptional invokespecial
  - S8059485, CVE-2015-0410: Resolve parsing ambiguity
  - S8061210, CVE-2014-3566: Issues in TLS

 

The new Java is properly detected by Oracle’s Java version tester at http://java.com/en/download/testjava.jsp :

slackware_java_7u75

Note about usage:

Remember that I release packages for the JRE (runtime) and the JDK (development kit) simultaneously, but you only need to install one of the two. The JRE is sufficient if you only want to run Java programs (including Java web plugins). Only in case where you’d want to develop Java programs and need a Java compiler, you are in need of the JDK package. Get them here.

The Java package (openjre as well as openjdk) has one dependency: rhino provides JavaScript support for OpenJDK.

Optionally: If you want to use Java in a web browser (which supports NPAPI plugins – this excludes Chrome & Chromium but you’ll be OK with all Mozilla [-compatible] browsers) then you’ll have to install my icedtea-web package too. While Oracle’s JDK contains a browser plugin, that one is closed-source and therefore Icedtea offers an open source variant which does a decent job.

If you want to compile this OpenJDK package yourself, you need to install apache-ant additionally. Note that the previous requirements of xalan & xerces packages have been dropped; ant will provide all required build functionality on its own now.

Have fun! Eric

5 thoughts on “Java update: openjdk 7u75 available


  1. Hi Eric,

    I am running a bit into trouble with needing to upgrade to jdk1.8 (java8) for some software I need to use. I can install the oracle jdk8 and change the JAVA_HOME to point to it, but rather would like to get an openjdk version to run, These seems available for ubuntu and fedora. Also IcedTea is at 2.5.3. Is that needed to compile for open-jdk8? Would it be feasable to compile this stuff myself (starting with yor buid-scripts). Could you give me some pointers or will I run in some depencecy cascade without end?


  2. rob,
    You cannot use any released icedtea version to compile OpenJDK 8. If you really want to, you will have to do your own research into the icedtea repository development code. My SlackBuild will not be useable.



  3. Ok that works to compile a .bz2 version. In the end I used the oracle jdk8.tar.gz, as that was directly ‘packageable’ for slackware with the build-scripts in /extra, to upgrade the jdk7. Had not much time to look into this further….


Leave a Reply to alienbob Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.