Chromium 54 packages

chromium_iconA new release of the Chromium source code was made available earlier this week. For me this is the first Chromium 54 package and unfortunately the SlackBuild script needed a lot of rework. Google is quite “dynamic” when it comes to developing and discarding in-house tools. The change from “gyp” to “gn” to generate the “ninja” makefiles was not trivial to incorporate into my build script. But I think I did it right, and I hope that no functionality has been lost in the new chromium package.

Packages for Slackware 14.2 and -current are now available from my repository. I’ll try to find time to make packages for Slackware 14.1 too, but a new set of Plasma 5 packages has a higher priority.

I hope to get up to speed after the weekend, and will try to release a new set of Live ISOs containing the new Plasma 5 after I have packaged that.

Cheers, Eric

32 thoughts on “Chromium 54 packages

  1. Eric —

    Installed and ran from the command line to test.

    Chromium does start ( ! very quickly ! ) but I get the stacktrace shown below in my Konsole Screen.

    Slackware64 14.2 + MultiLib + NVidia 367.57 Blob

    If it helps, I saw the same thing on chromium ‘the version before last’ ,
    chromium-52.0.2743.116-x86_64-1alien

    — kjh

    $ chromium &

    libva info: VA-API version 0.38.1
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/nvidia_drv_video.so
    libva info: Found init function __vaDriverInit_0_38
    libva info: va_openDriver() returns 0
    libva info: VA-API version 0.38.1
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/nvidia_drv_video.so
    libva info: Found init function __vaDriverInit_0_38
    Received signal 8 FPE_INTDIV 7f15338493ea
    #0 0x5630e49e563e
    #1 0x5630e49e59f9
    #2 0x7f1547cab3b0
    #3 0x7f15338493ea
    #4 0x7f153384c068
    #5 0x7f153384c0a6
    #6 0x7f153384c27c
    #7 0x7f153384d060
    #8 0x7f1533c66ffe
    #9 0x7f1533c67de4
    #10 0x5630e87ff3ce
    #11 0x5630e880108f
    #12 0x5630e8801271
    #13 0x5630e88016ef
    #14 0x5630e87f98c9
    #15 0x5630e87f569d
    #16 0x5630e67d0639
    #17 0x5630e67cb300
    #18 0x5630e67cc3dc
    #19 0x5630e6769822
    #20 0x5630e67cb201
    #21 0x5630e5784a46
    #22 0x5630e4a66800
    #23 0x5630e4a030fa
    #24 0x5630e4a048dd
    #25 0x5630e4a04d85
    #26 0x5630e4a05e59
    #27 0x5630e4a05e9d
    #28 0x7f1546ef7797 g_main_context_dispatch
    #29 0x7f1546ef79c8
    #30 0x7f1546ef7a6c g_main_context_iteration
    #31 0x5630e4a05c4a
    #32 0x5630e4a2214a
    #33 0x5630e67c7ab2
    #34 0x5630e45ffe72
    #35 0x5630e45ff111
    #36 0x5630e30f5c0a
    #37 0x7f1541c187d0 __libc_start_main
    #38 0x5630e30f5a69
    r8: 0000000000000000 r9: 0000000000000000 r10: 00007f1541fbbb78 r11: 00007f1541fbbb78
    r12: 0000000000000000 r13: 00007ffdb4c9454c r14: 00007f153385605c r15: 00005630ecaeefa0
    di: 00005630ecaef0f0 si: 0000000000000000 bp: 0000000000000000 bx: 00005630ecaef0f0
    dx: 0000000000000000 ax: 0000000000000000 cx: 0000000000000000 sp: 00007ffdb4c94520
    ip: 00007f15338493ea efl: 0000000000010246 cgf: 0000000000000033 erf: 0000000000000000
    trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
    [end of stack trace]
    [17300:17327:1104/035234:ERROR:browser_gpu_channel_host_factory.cc(113)] Failed to launch GPU process.


  2. p.s. I forgot to say thank you.

    Thank You ! 🙂

    Also, chromium seems to run just fine but I’ve got no HW acceleration.



  3. Looking back on the past two months, I really needed the downtime. Exhaustion overtook me in the early weeks of September and I have not been doing much (other than work and transferring my work) since then until my last day as an IBMer.

    But this week, I am at home without worries or stress. I have been baking “worstenbroodjes”, see https://nl.wikipedia.org/wiki/Brabants_worstenbroodje – this sausage roll is actually part of UNESCO’s dutch cultural heritage list. And cleaning the house, bit by bit. And baking bread… one boule of dough is currently rising.
    But, more Slackware package updates will start showing up too.


  4. Thanks for doing these chromium builds, they are really awesome, but with the last versions I am getting this on startup and no gpu support (chrome://gpu shows “software only”).

    [10996:10996:1105/181035:ERROR:sandbox_linux.cc(343)] InitializeSandbox() called with multiple threads in process gpu-process.
    Received signal 11 SEGV_MAPERR 000000000000

    chromium-52.0.2743.116-x86_64-1alien is the last which works here with gpu support, but with chrome it works fine… Not sure what the problem could be 🙁 I am on slackware64-current with amdgpu/mesa drivers.


  5. Hi Eric! Thank you! Chromium seems to run just fine. Two points:
    1. In Plasma (KDE), Chromium again talks to the KDE Wallet OR has its own wallet; in any case, the good thing is that I don’t have anymore to relogin to sites upon each boot. GOOD!

    2. I saw you added “libtinfo”. Is that necessary for running chromium? Is that necessary to install for any other purpose than compiling chromium?

    Thanks!!


  6. Micha – might be related to a patch I apply to Chromium which enables VAAPI support (i.e. GPU hardware accelerated video playback). By default, Google will only enable that support on ChromeOS. Could be that this patch introduces an incompatibility for some video drivers.




  7. That is a question you have to ask Patrick, not me. If it were for me, the switch from KDE 4 to Plasma 5 would already have occurred but I do not own Pat’s agenda.


  8. Sorry Alien if my question bother you, it was just a friendly question, I thought he would ask you about your work on Slackware packages once it is a very good work. Really sorry and thank you for your good work on that.


  9. @Micha

    I’ve same problem on Nvidia binary divers from some time. If you feel brave, you can run chromium with “–disable-gpu-sandbox” parameter. This fix this problem but your browser will be less secure.


  10. @alienbob

    thanks for the hint with VAAPI, I just compiled chromium 54.0.2840.100 without that patch and it seems to work again now 🙂

    I also needed to do this, else the compile would abort:
    ln -s /usr/lib64/libncurses.so.5 /usr/lib64/libtinfo.so.5


  11. Micha, yes the VAAPI patch is perhaps a candidate for removal if it causes more issues than it solves.

    The chromium.SlackBuild mentions in the “Build needs” section: “libtinfo (provides symlinks required by downloaded clang);”. I created a “libtinfo” package which does precisely that and nothing more: create symlinks for libtinfo.so* pointing to libncurses.


  12. Hi Eric
    I’ve tried your new 32-bit slackware-14.1 versions of chromium-54…..

    I get the “Aw Snap” page due to “Received signal 11 SEGV_MAPERR” on some webpages but not all…. (e.g. google.co.uk is OK but weebly.com snaps)

    I’ve tried on both nvidia and intel graphics and get same error.
    I’ve also tried disabling sandbox and still get same error

    Many thanks for all the packages you make available – much appreciated.

    Cheers
    peebee



  13. Hi Eric
    Tests were on a pristine new installation – no extensions – only 2 plugins: pdf-viewer and pepperflash – disabled both plugins but still got error…..


  14. Hi Eric, greetings. For a project im working on I have to use an older chromium version (59.0.3071.135), and I tried to build it using your slackbuild along with the source I downloaded from the official chromium web site
    https://chromium.googlesource.com/chromium/src.git/+/59.0.3071.135
    However when I try to build it, I got the following error. Do you know how to fix it?

    Building …
    — Unbundling system libraries from chromium sources.
    — Change bundled to system libraries in chromium sources.
    Traceback (most recent call last):
    File “build/linux/unbundle/replace_gn_files.py”, line 79, in sys.exit(DoMain(sys.argv[1:]))
    File “build/linux/unbundle/replace_gn_files.py”, line 63, in DoMain os.path.join(source_tree_root, path + ‘.orig’))
    File “/usr/lib/python2.7/shutil.py”, line 82, in copyfile with open(src, ‘rb’) as fsrc:
    IOError: [Errno 2] No such file or directory: ‘/tmp/build/tmp-chromium/chromium-56.0.2924.76/third_party/flac/BUILD.gn’
    ./chromium.SlackBuild FAILED at line 413

    I searched in the tmp directory and noticed that the directory flac is not present in the uncompressed source code and I noticed you selected “flac” in the gn_system_libraries section on the slackbuild, maybe there’s a relation…

    Thanks





  15. Saul, the URL you gave is what I am currently using to compile chromium 62. There is no guarantee that that is still capable of compiling chromium 59.

    You will find the chromium.SlackBuild I used for the 59 release here: http://bear.alienbase.nl/cgit/asb/commit/chromium/build/chromium.SlackBuild?id=8d216775a928b2a4ab46cda8a967d357a2ad943c
    And the patches I had at that time are here (same git ID basically: http://bear.alienbase.nl/cgit/asb/tree/chromium/build/patches?id=8d216775a928b2a4ab46cda8a967d357a2ad943c

    Still, no guarantees that this will compile on your box. You never told what release and architecture of Slackware you are running.


  16. Also saul, I think your downloaded sources may be the culprit. My archive copy of the original source tarball does have your missing flac file. And the online copy of that source tarball, https://commondatastorage.googleapis.com/chromium-browser-official/chromium-59.0.3071.86.tar.xz also contains “chromium-59.0.3071.86/third_party/flac/BUILD.gn.”

    By the way, did you notice that your error message mentions “chromium-56.0.2924.76/”? What’s with that incorrect version number?


  17. Thanks a lot for your help Eric. Right now the compilation is around 60% (16,500/27,800), yeahhh!!. I appreciate your attention 🙂
    You have given me an strong argument against the people that wants to remain with the windows stuff in this University, since they argue the lack of software or support as a reason for not switching to slackware (or linux in general). There´s a big community willing to support you and there are brilliant minds behind the scenes like you. People around here is still reluctant to make the switch, but is just a matter of showing them the brighter side of things.

    In regards to your comment: “did you notice that your error message mentions “chromium-56.0.2924.76/”? What’s with that incorrect version number?”
    Yes, I noticed that. The reason is that I tried to compile different versions (56, 58, 59) but I always found the same problem: the missing flac folder.
    Also in regards to the other comment “I think your downloaded sources may be the culprit. My archive copy (…) does have your missing flac file.”
    I thought the site https://chromium.googlesource.com/chromium/src.git/
    was the official site that contained the source code… I downloaded versions 59, 58 and 56… and in all of them the flac folder (and contents) is missing… maybe a mistake from them? Unless they decided to remove the third party folder from the tarballs…



  18. I dont understand… I compiled the sources succesfully… a .txz file was created… I installed the package…however the program is crashing. I always thought that if you’re able to compile, you should also be able to run the binary… is this statement correct?


  19. saul, a program that compiles without errors can still fail at runtime. Often caused by the runtime dependency libraries. You may have to revert to tools like gdb to find out where the crash occurs, if nothing relevant is showing up in your terminal if you start chromium from the prompt.


  20. Eric:
    In order to use use gdb which lines do I need to add/modify in your slackbuild to compile again? Im using gcc, not clang…

    Regards,




  21. Hello Eric. In some versions of your slackbuilds you included the following lines, what is the meaning of each line? or where can I read about them?
    _chromium_conf=(
    ‘use_cups=true’
    ‘use_gio=false’
    ‘use_gold=false’
    )

    Regards,


  22. Please do not keep asking questions in the comments section of old articles. I have had enough of it now. Your questions have no relation to the article.
    Final answer therefore: read the chromium documentation if you really want to know the answer. Delete those lines if you want to learn if they make a difference.


Leave a Reply to saul Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.