Index of /ktown/13.37/4.6.5

[ICO]NameLast modifiedSizeDescription

[DIR]Parent Directory  -  
[TXT]README07-Jul-2011 08:31 4.8K 
[DIR]x86/17-Jul-2014 06:30 -  
[DIR]x86_64/17-Jul-2014 06:31 -  

KDE4.6
======

This is the KDE Software Compilation 4.6.5 for Slackware 13.37/current.
It is the fifth and last monthly bugfix release for the KDE SC 4.6 series.
Next in line is KDE 4.7 which probably will see the light of day in august.

Most noticable about KDE 4.6 is that it no longer depends on HAL.  And since
the version of X.Org found in Slackware 13.37 does not use HAL either
(likewise for XFCE 4.8.x), adding KDE 4.6.x and XFCE 4.8.x to Slackware in
future will be big step towards removal of HAL.
HAL is no longer maintained by its developer, and has been superceded by udisks.

You have to run Slackware 13.37 (or slackware-current) in order to use
these packages.  Do not expect these packages for KDE 4.6.5 to work on
Slackware 13.1...
If you want KDE 4.6.5 you are encouraged to upgrade to Slackware 13.37 !

My set of KDE SC 4.6.5 packages replaces the older version of KDE (4.5.5)
which comes with Slackware.  There are several packages in the "deps" directory
that you need as well; these are updated Slackware packages or new packages
(grantlee, libatasmart, libbluedevil, libssh, sg3-utils, udisks and upower
are new packages for instance).  Upgrading/installing these "deps" packages
is required for the proper functioning of KDE 4.6.5.

NOTE:
About PIM (kdepim and kdepim-runtime) packages:
* The laatest stable versions of kdepim and kdepim-runtime - 4.6.1 - are
  available in the KDE 4.6.5 collection!
  The PIM developers have been working on the 4.6 release for a long time, and
  4.6.1 is their first bugfix version.
  The PIM software release versions will be synchronized again with the main
  KDE SC release schedule parallel with KDE SC versions, starting with 4.7.0.
* Please note that if you do not want to upgrade your PIM applications yet,
  you can keep using kdepim and kdepim-runtime 4.4.10 which are included
  with Slackware 13.37 and -current.
  That version is still compatible with KDE 4.6.5.

NOTE:
About the language packs (KDEI) - for Slackware 32-bit as well as 64-bit:
* KDE localizations (language packs) are available in "x86_64/kdei". You only
  need one package (for your own language).  Don't let the "x86_64" in the
  directory name fool you, the language packs are useable on both platforms.
* Like in Slackware's own KDEI 4.5.5 packages, I have merged the language files
  of kdepim-4.4.10 into the KDEI packages, so that you can use the PIM apps
  like kmail in your own language if you decide to keep Slackware's version of
  kdepim and kdepim-runtime.
* If you decide to install kdepim/kdepim-runtime 4.6.1, you will find that
  that package already includes the translations/localizations.

NOTE:
I have not added the kdevelop and kdevplatform packages which I shipped with
my first set of KDE 4.6 packages.  Compatible versions of these packages are
now in Slackware 13.37 so that there is no longer a need for me to build them.

NOTE:
Slackware's own polkit-kde-1 package must be removed before you start using
KDE 4.6.5!
Its functionality was split out into two new packages: polkit-kde-agent-1 and
polkit-kde-kcmodules-1, both of which you can find in my 'kde' directory.

-------------------------------------------------------------------------------

Below are the steps you take to install or upgrade to KDE 4.6.5.

Make sure you are not running KDE or even X!  If you are running an X session,
log out first, and if you are in runlevl 4 (graphical login) you first have to
go back to runlevel 3 (console) by typing "init 3".

To make it easy for you, this is  an easy one-line command that downloads the
whole 4.6.5 directory with all the sources, and 32bit and 64bit packages:

  # rsync -av rsync://alien.slackbook.org/alien-kde/4.6.5 .

Assuming you downloaded the complete directory tree "4.6.5" with everything
below, you change your current directory to where you found this README
(which is the directory called '4.6.5').  If you used the "rsync" command
above, then that would mean a simple:

  # cd 4.6.5

From within this directory, you run the following commands as root.

  On Slackware 32-bit:
  # upgradepkg --reinstall --install-new x86/deps/*.t?z
  # upgradepkg --reinstall --install-new x86/kde/*.t?z
  # removepkg polkit-kde-1

  On Slackware 64-bit:
  # upgradepkg --reinstall --install-new x86_64/deps/*.t?z
  # upgradepkg --reinstall --install-new x86_64/kde/*.t?z
  # removepkg polkit-kde-1

  If you already have one or more non-english language packs installed:
  # upgradepkg x86_64/kdei/*.t?z
  
  If you want to have a non-english language pack installed but none is
  currently installed, substitute your country code instead of the 'XX'
  in the next command:
  # upgradepkg --install-new x86_64/kdei/kde-l10n-XX-*.t?z

Then reboot your system.

===============================================================================
Eric Hameleers - alien at slackware dot com - 07jul2011