Main menu:

Sponsoring

Please consider a small donation:

 

 

Or you can donate bitcoin:

 

Thanks to TekLinks in Birmingham, AL, for providing colocation and bandwidth.

Page Rank

Fame

FOSS Force Best Blog--2013 Award

Recent posts

Recent comments

About this blog

I am Eric Hameleers, and this is where I think out loud.
More about me.

Search

My Favourites

Slackware

Calendar

November 2014
M T W T F S S
« Oct    
 12
3456789
10111213141516
17181920212223
24252627282930

RSS Alien's Slackware packages

RSS Alien's unofficial KDE Slackware packages

RSS Alien's multilib packages

Meta

What you do when it rains

alien

I had a great week in Bruges, Belgium. Visited the brewery “De Halve Maan” and had a tour of the new brewing hall as well as the museum with all the ages old brewing equipment. It ended with a free “Brugse Zot” blonde beer, unfiltered (you can get the unfiltered version only in the brewery’s own restaurant on-site). It really tasted great, more flavors than the bottled version.

I will try to post some of the pictures I took while roaming the city of Bruges (I nearly took 200) because it is a very pretty – Bruges is one of Unesco’s World Heritage sites. But anyway, we did not have rain during our stay (a few small showers perhaps). The rain started when we went back home. With that rain, I was less inclined to go out and walk for a bit, or work in the garden. Bread making is one of the things I am doing today (using my sourdough starter which survived a week in the fridge exceptionally well). But after a week of no computing, I wanted to do something again when I got home.

So I uploaded the KDE 4.14 packages and posted the blog article, all of which I had already prepared before traveling to Bruges. And then I looked at what else had been happening during my absence. Not much really :-) Some new systemd related threads on LinuxQuestions.org, which I am trying to stay out of (it’s a pretty hairy discussion in there), and some more talk about Skype 4.3 which needs PulseAudio now.

Perhaps I will pick up zerouno’s successful effort to package all the required 32-bit libraries along with the Skype binaries (he did not have to bother with PulseAudio then, so I think it will be more complex to make it work now)… if I find the time.

On Google+ I had attempted to find some answers to creating an OpenVZ container template for Slackware. I had hoped there would be updates during my holidays, but unfortunately the one guy (who also reads this blog of mine I believe) who has worked professionally with openvz and Slackware and whom I asked for advice did not answer. Probably too busy with his girl friend. Anyone who can help me out, please leave me a note. The G+ post contans a link to the script I wrote for the creation of that Slackware template.

kde44 I did have time this weekend to package KDE 4.13.3 for Slackware 14.1 – as promised when I wrote about KDE 414 for Slackware-current.

The KDE 4.13.3 packages for Slackware 14.1 are available at the usual location,  http://taper.alienbase.nl/mirrors/alien-kde/14.1/latest/. Those of you who like (or need) to use a stable Slackware version will now have the opportunity to enjoy a much-improved KDE. It includes the latest Calligra office suite and also the kdeconnect package (to interface with your Android phone from within KDE)  has been upgraded and has a lot more functionality now.

calibreico I also looked at the weekly update of Kovid Goyal’s Calibre package.

To my surprise he has promoted his beta version of Calibre 2 to production sooner than I expected which creates a dilemma for me. The new version 2.0.0 is no longer based on Qt4 but instead Kovid uses Qt5 for Calibre now, which allowed him to eliminate several longstanding Qt4 related bugs. My dilemma is, how should I treat the transition to Qt5 ? Should I embed the Qt5 libraries into the Calibre 2 package like I used to do long ago for Qt4 (which will greatly increase the package size) or should I request of you (users of my Calibre package) to install my Qt5 package along with the new Calibre? I would like your feedback before I decide to start building a Calibre 2 package. In the meantime, the “old” calibre-1.48.0 package will remain available in my repository.

ARM_powered_300px There were two questions in my old blog pages about the status of my hardfloat ARM port. I must say, the economical crisis and the condition of our remaining parents have resulted in me having a lot less free time, and the ARM port was a victim of that. I am at a point with that port that I need to re-sync to the latest stable Slackware and then transfer the packages to a real machine… I am a bit scared of that last part. Stuart’s Slackwarearm is very successful at installing onto ARM devices, because he uses a (modified version of the) real Slackware installer for that. WIth my ARM port I am noy yet sure if I want a “Slackware-like” installation using the setup script, or create an image file which you just have to copy to your ARM device. Note that the hardware which I had in mind for my port, is the Chromebook, or tablets even, Unlike the older embedded Linux devices, those are typically equipped with a ready-made OS image instead of running an installer. But the ARM port is not dead! I just need to get my act together.

Have fun! Eric

Comments

Comment from Didier Spaier
Posted: August 24, 2014 at 15:07

Hi Eric,

if you are bored on a rainy day, maybe you could review the Dutch translation of the big Slint file that you began and that have been recently completed by Dik:
https://www.transifex.com/projects/p/slint/resource/slint/
– yes, I am opportunist at times ;)

I will soon upload installers including it to ease reviewing it in context.

Other than that I’m guilty of the big new thread about “how can Slackware avoid relying on systemd in the future”. It was hard to keep it on topic as usual but with the help of unSpawn it’s back on tracks at the moment, so your input there is warmly welcome.

Cheers, Didier

Comment from Niki Kovacs
Posted: August 24, 2014 at 15:12

Eric,

A self-contained Skype package would be an excellent idea, and very much appreciated. A couple of clients of mine have been running Skype on their Slackware-based desktops, and now they’re calling me. Not with Skype, mind you, but on the phone. Wanting to know why Skype stopped working. Here in South France we also have bad weather, sort of. The sky is blue, and we “only” have a mild 25°C instead of the usual 35°C at this time of year. I’m cheerfully working on my KDE-based MLED respin.

Cheers,

Niki

Comment from Niki Kovacs
Posted: August 24, 2014 at 15:15

BTW, I just finished writing a mini-HOWTO about handling your Multilib packages with slackpkg+ on my new Slackware-only blog.

http://unixgarden.wordpress.com/2014/08/24/installer-un-jeu-de-bibliotheques-de-compatibilite-32-bit-sur-slackware64/

Comment from Alex
Posted: August 24, 2014 at 15:46

Hi Eric,

great work all over, again, from your side. Thanks for all of this.

Regarding Calibre, I’d prefer the unbundled version, i. e. install Qt5 separately. It would be ideal, if this was possible with as few side effects for Qt4 based things as possible. Also, I sincerely hope to see Qt5 on “official” Slackware-current, soon. In this case it might make sense, if your and Patrick’s Qt5 plans would be aligned, in order to provide a smooth migration path for users.

Alex

Comment from alienbob
Posted: August 24, 2014 at 16:08

Hi Didier

Yes, reviewing the dutch Slint translation was next on my list, along with louigi600′s http://docs.slackware.com/howtos:misc:running_an_access_point_from_a_slackware_box artcle.

Comment from alienbob
Posted: August 24, 2014 at 16:10

Alex,

I already have a Qt5 package which can be installed on Slackware-current without any negative side-effects to Slackware’s Qt4 based applications. At the moment this Qt5 package is still part of my Plasma 5 set for KDE, but it can (and will) be copied to my main slackbuilds repository if Calibre needs it.

Comment from alienbob
Posted: August 24, 2014 at 16:14

Hi Niki

Good! There are not so many Slackware-centric blogs in french, I think :-)

Comment from Jen
Posted: August 24, 2014 at 16:42

Bread: the other day I was feeding some starter to make bread. Early afternoon, I smelled beer, and was going to comment to my fiancé that it was a bit early in the day, when I realized it was the starter. :)

Calibre: whichever’s easiest, so long as there’s no trouble for Qt4-based things.

Comment from Niki Kovacs
Posted: August 24, 2014 at 16:47

Eric,

I don’t want to celebrate too early, but there is right now a significant chance I might finally base my future Linux trainings as well as my upcoming Linux book on Slackware as a sane base. There was and still is much (!) convincing involved, but I’m slowly getting there.

Comment from Me
Posted: August 24, 2014 at 16:48

I rather see an Qt5 bundled package.

Comment from Brad R.
Posted: August 24, 2014 at 17:18

If you already have a separate QT5 for Plasma5, it seems easiest to just use that for Calibre 2.0.

Comment from alienbob
Posted: August 24, 2014 at 19:13

Hi Jen. How much starter do you keep? I tend to keep the quantity to a minimum since I do not store it in my fridge and therefore it needs regular feeding. I think I have a 100 grams.
I also seal the lid airtight which prevents the beery smell from emerging… a bit of a pity actually. A new sourdough bread is almost ready to be put into the oven by the way.

Comment from Alex
Posted: August 24, 2014 at 20:32

Hi Eric,

yep, of course I knew of your Qt5 package, but as I haven’t used it, yet, I wasn’t aware that it’s part of Plasma5. As more applications tend to be based on Qt5, it makes ever more sens, to single Qt5 out and provide it separately. Then, applications like Qupzilla (web browser) and Calibre, and desktops like LXQt and KDE could use it, and it would have to be installed only once an a system.

Despite the initial convenience of a packaged bundle (of Calibre with Qt5), a separate Qt5 would be more flexible and light the way to future Slackware releases, I guess… Well, we guess, only Pat knows. ;)

Alex

Comment from Bill Kirkpatrick
Posted: August 24, 2014 at 20:53

Eric,
I’ve already loaded your qt5 packages with the other KDE 5.0.1 deps, so would rather have calibre unloaded.
Here on the Texas gulf coast, we could use some of those showers. Other parts of the country have gotten too much, had some flooding, but we are way behind & have a burn ban in effect, no outside burning at all.
Regards & thanks.

Comment from Ricardo J. Barberis
Posted: August 24, 2014 at 21:14

I Eric, thanks for you KDE 4.13 packages for Slackware 14.1.

I don’t use Calibre but if I did, I would prefer an unbundled version, as a separate Qt 5 package(s) could be useful for other Qt 5-dependent packages.
And maybe also for updating said packages (smaller downloads).

In my case, I installed Qt 5.3 from slackbuilds.org to compile Otter (https://github.com/Emdek/otter, an open source web browser that tries to mimick Opera 12′s interface).

What do I do on rainy days? Well, I stay at home and read your blog of course! :)

Cheers.

Comment from Jen
Posted: August 24, 2014 at 21:32

Nice! I keep forgetting to start the bread in the morning, so I have to keep feeding the starter that’s out…

Generally I only have about a cup of starter at a time. I keep it in the fridge and feed once a week. When I feed it, I’ll toss half (or use that half to make bread, pancakes, whatever). The last starter I had to reduce it to about 1/4, otherwise it would exhaust its feeding in a couple of days.

I learned my lesson the hard way on sealing a tightly-sealed jar of starter (or kimchi). That juice goes *everywhere*. :)

Comment from vinicius
Posted: August 24, 2014 at 21:49

Eric, I’ve left a note on that G+ thread. I’m familiar with OpenVZ and have access to production servers. I can help you with the script.

Comment from Deny Dias
Posted: August 24, 2014 at 22:25

Eric,

Calibre2 and Qt5 in separate packages looks the right path to me, better than a monolithic package. Decoupling, KISS… (the 2nd S doesn’t apply to you)

I’m glad to see you were off for a week from computer stuff, taking your time, having fun, doing bakery… And even away you keep track of everything! That’s a ‘multidimensional brain’ (as someone told me in #slackware) in action. :)

Comment from Deny Dias
Posted: August 24, 2014 at 22:38

I forgot to mention: it would be great if Slackware for ARM includes some RaspberryPi tenderness in the future.

RaspPi looks like (no proof here) a much widespread platform today when compared to Chromebooks. Being cheaper and widely available in the wild, RaspberryPi could be a great place to teach niños the beauty of Linux closest to its roots.

RaspBian, systemd… opportunity… simplicity… SlackwarePi…

Comment from alienbob
Posted: August 24, 2014 at 22:43

Hi vinicius. Google had flagged your comment as spam, so I just restored it. It is now visible in the thread.
I’ll look at your pastebin entry tomorrow and then open another ticket at the hosting company to get this thing rolling.

Comment from alienbob
Posted: August 24, 2014 at 22:45

Deny Dias, the Raspberry Pi is unable to run my hardfloat ARM port, its CPU is of the armv6 type which does not have a floating point unit in hardware (you’ll need armv7 or higher). The existing SlackwareArm works well on it though.

Comment from Deny Dias
Posted: August 24, 2014 at 22:52

Nice! I’m going to give it a try on mine… Thanks for the info. If they play nice together, that will be the perfect gift for the kids around… myself included.

Comment from Regnad Kcin
Posted: August 25, 2014 at 01:24

Coincide – what you do when it’s raining.

Comment from Helios
Posted: August 25, 2014 at 10:55

I found something in xinitrc.plasma :

When I tried to run “startx” it did not work, complaining that “qdus” could not be found.

changing
“export PATH=$KF5/bin:$KF5/lib64/qt5/bin:$PATH”
into
“export PATH=$KF5/bin:/usr/lib64/qt5/bin:$PATH”
solved the problem,

or maybe my installation was not complete (a missing link in /opt/kf5/lib64/qt5 ?)

Comment from alienbob
Posted: August 25, 2014 at 11:10

Hi Helios

My hunch is that you did not logout and log back in again after you installed my qt5 package.

The profile script /etc/profile.d/qt5.sh takes care of adding /usr/lib64/qt5/bin to the $PATH . A change to xinitrc.plasma is therefore not needed.

Comment from Janis
Posted: August 25, 2014 at 12:47

Hi! It seams yo forgot about ktorrent and libs as to-be-kept. Or 4.13.3 has it deeply buried somewhere?

Comment from Janis
Posted: August 25, 2014 at 13:21

As for calibre – it would be nice to have it runing on 14.1.

Comment from chrisretusn
Posted: August 25, 2014 at 15:02

Thanks for all that you do. Ktown 4.14.0 up and running. On

On Calibre. I prefer a separate Qt5 install rather than bundled with. I find that I have a few other programs I use that require Qt5. Stellarium for example now requires Qt5 with it latest upgrade. I was considering installing Qt5 from Slackbuilds when I noted the Qt5 package in “deps” of Plasma 5. While i have not tried Plasma 5 yet, I did install the Qt5 package. Stellarium has now been upgraded. :)

Comment from alienbob
Posted: August 25, 2014 at 15:05

Hi Janis

Indeed, I should have mentioned in the README that you also have to gran the libktorrent and ktorrent packages from Slackware’s own kde/ directory. Those are the latest versions available online.
I never use ktorrent myself so I had not noticed the README does not mention them.

Comment from fabio
Posted: August 25, 2014 at 16:09

rsync error for kde-4.13.3
error starting client-server protocol.

Comment from alienbob
Posted: August 25, 2014 at 16:15

Fabio, more info please. For instance, what server? What (complete and exact) commandline? What (complete and exact) error message?

This command worked without any error for me:

$ rsync -av rsync://taper.alienbase.nl/mirrors/alien-kde/14.1/4.13.3 /tmp/

Comment from Matt
Posted: August 25, 2014 at 16:16

Hi Eric,

Thanks for the 4.13.3 packages! The only “issue” I found in updating from stock 14.1 is the last line in the instructions. It tells me to remove the kdnssd package, but there is no such thing on my system. I did a full install of all packages back when I installed Slackware, along with the multilib stuff.

Thoughts?

Comment from metageek
Posted: August 25, 2014 at 19:02

Hi Eric,

1st thanks for building the calibre packages, I have been downloading them regularly. I would prefer QT5 separate, but since I am running 14.1 I don’t know if this will work. I may have to stay on the old calibre…

Comment from Janis
Posted: August 25, 2014 at 20:00

The old story on auto-mount: I’d be happy getting advice on how to automatically mount usb devices _without_ choosing an option from device manager pop-up list. So, the expected action is simply mount the device in fs if there is no user intervention after plugging in the device. I inspected KDE 4.11.5 device actions, but there isn’t anything of value – I can not locate mentioned fall-back action.

Comment from fabio
Posted: August 25, 2014 at 22:08

ok. solved by itself. the original error was about max number of connections been reached. Already downloaded. thanks and sorry for bothering you for nothing alienbob

Comment from Sam Albuquerque
Posted: August 26, 2014 at 14:49

I installed Skype 4.3 using Slackbuilds and have not installed PulseAudio. Skype runs fine without it. Not sure of audio as it’s a work desktop and I don’t need audio there anyway.

Comment from Niki Kovacs
Posted: August 26, 2014 at 17:41

@Sam Albuquerque. I’m not sure I understand your message. You mean Skype runs fine but has no audio? This makes no sense.

Comment from Janis
Posted: August 26, 2014 at 20:57

On the KDE 4.12.5 leftovers – what about bluedevil and KDE 4.13.3? I do not see it in package list.
Not that I need it – just for the clarity of experiment.

Comment from alienbob
Posted: August 26, 2014 at 23:07

Hi Janis

Indeed I seem to have lost bluedevil from the README at some point. It needs to be installed from Slackware’s KDE/ directory (libbluedevil which resides in L/ is of course also needed). I always build KDE in the presence of bluedevil.

I have updated the README files.

Comment from alienbob
Posted: August 26, 2014 at 23:09

Niki, it makes complete sense. I run Skype 4.3 too here on this computer. I never use Skype audio on my desktop computer, just the text chat. Pulseaudio is not needed if you only use the text chat functionality.
I was forced to migrate to Skype when MSN got decommisioned by Microsoft.

Comment from Brian Lawrence
Posted: August 29, 2014 at 14:27

Hi Eric,
Thanks for 4.13.3. Upgraded from 4.12.5 yesterday, and everything seems OK, as usual.
– Brian

Comment from Sam Albuquerque
Posted: September 1, 2014 at 16:52

@Niki like Eric mentioned, I only use text chat and hence don’t need the audio functionality of skype, which i think depends on pulseaudio. The only reason I use skype is for team discussions at work.

Comment from gauchao
Posted: September 8, 2014 at 22:26

Hi Eric. Maybe you could embed the Qt5 libraries into the Calibre 2 package even though it will increase the package size. Thank you!

Comment from vinicius
Posted: September 28, 2014 at 20:19

Eric, I worked on creating the slackware template for OpenVZ. I was able to fully automated it, under the current limitation of packing for kernel 2.6 and that problem with glibc being ‘too new’. I’ve made the packing script available, if you’re still interested: http://is.gd/rR8l8r

Comment from alienbob
Posted: September 29, 2014 at 10:25

Hi vinicius

Interesting! I also see that you noticed that the glibc in Slackware64 14.1 does not work, but the multilib glibc does (after I recompiled the packages last month).

I will try out your script and coërce the hosting provider into letting me install it.

Your final remark in the script “the name of the tarball must start with slackware” – is that how OpenVZ determines that it must use the Slackware specific scripts for network and root password?

Comment from vinicius
Posted: September 29, 2014 at 18:10

Eric, yes, it uses the name of the tar ball to know that it’s slackware and registers it in the file veid.conf. Then on boot it select the proper scripts to setup hostname and ip address.

Write a comment