Main menu:

Sponsoring

Please consider a small donation:

 

 

Or you can donate bitcoin:

 

Thanks to TekLinks in Birmingham, AL, for providing colocation and bandwidth.

Page Rank

Fame

FOSS Force Best Blog--2013 Award

Recent posts

Recent comments

About this blog

I am Eric Hameleers, and this is where I think out loud.
More about me.

Search

My Favourites

Slackware

Calendar

October 2014
M T W T F S S
« Sep    
 12345
6789101112
13141516171819
20212223242526
2728293031  

RSS Alien's Slackware packages

RSS Alien's unofficial KDE Slackware packages

RSS Alien's multilib packages

Meta

Package rebuilds for KDE 4.6.0

For those of you who are using my KDE 4.6.0 packages:

Lately there have been some massive changes to the software in slackware-current. New versions of boost, libexiv2, perl made it necessary to re-compile several of my own KDE 4.6.0 packages. Perhaps you already noticed that Gwenview no longer worked, or you were having issues with plasmoids.

So, check out my ktown repository packages and upgrade the following:

kdeartwork, kdebase-runtime, kdebindings, kdegraphics, kdeplasma-addons

They have the build number “2alien

Good luck, Eric

Comments

Comment from Widya Walesa
Posted: February 13, 2011 at 16:14

Thank you for the updates. Syncing it right now :)

Comment from LoneStar
Posted: February 13, 2011 at 16:18

Thanks as usual :)

Comment from escaflown
Posted: February 13, 2011 at 18:41

Thanks Eric! Just for the sake of curiosity: after the last update in current, I noticed the return of an old problem where dbus was consuming almost 100% of my CPU usage because of akonadiserver process. This was fixed when I installed your new kde 6.0 packages. could you point me to the eventual culprit packages of such a behavior? (just for information value)

Pingback from [SOLVED] Anyone else having problems with the new exif2?
Posted: February 14, 2011 at 10:41

[...] yesterday had made available updated packages, have a look on his [...]

Comment from toto
Posted: February 15, 2011 at 11:52

There are still problems with the game ‘prboom’ which worked with kde-4.5.5

*** glibc detected *** prboom: free(): invalid pointer: 0x00000000008b0a70 ***
======= Backtrace: =========
/lib64/libc.so.6(+0×79754)[0x7feb42799754]
/usr/lib64/tls/libnvidia-tls.so.260.19.36(+0x8bb)[0x7feb4111a8bb]
======= Memory map: ========
00400000-004b5000 r-xp 00000000 08:01 1111081 /usr/local/bin/prboom
006b5000-006d9000 rw-p 000b5000 08:01 1111081 /usr/local/bin/prboom
006d9000-008ee000 rw-p 00000000 00:00 0 [heap]
7feb3b49b000-7feb3bbc3000 rw-p 00000000 00:00 0
7feb3bbc3000-7feb3c48d000 rw-s 00000000 00:04 4751365 /SYSV00000000 (deleted)
7feb3c48d000-7feb3c48e000 —p 00000000 00:00 0
7feb3c48e000-7feb3cc8e000 rw-p 00000000 00:00 0
7feb3cc8e000-7feb3cc9a000 r-xp 00000000 08:01 2890476 /lib64/libnss_files-2.13.so
7feb3cc9a000-7feb3ce99000 —p 0000c000 08:01 2890476 /lib64/libnss_files-2.13.so
7feb3ce99000-7feb3ce9a000 r–p 0000b000 08:01 2890476 /lib64/libnss_files-2.13.so
7feb3ce9a000-7feb3ce9b000 rw-p 0000c000 08:01 2890476 /lib64/libnss_files-2.13.so
7feb3ce9b000-7feb3cea6000 r-xp 00000000 08:01 2890478 /lib64/libnss_nis-2.13.so
7feb3cea6000-7feb3d0a5000 —p 0000b000 08:01 2890478 /lib64/libnss_nis-2.13.so
7feb3d0a5000-7feb3d0a6000 r–p 0000a000 08:01 2890478 /lib64/libnss_nis-2.13.so
7feb3d0a6000-7feb3d0a7000 rw-p 0000b000 08:01 2890478 /lib64/libnss_nis-2.13.so
7feb3d0a7000-7feb3d0be000 r-xp 00000000 08:01 2890473 /lib64/libnsl-2.13.so
7feb3d0be000-7feb3d2bd000 —p 00017000 08:01 2890473 /lib64/libnsl-2.13.so
7feb3d2bd000-7feb3d2be000 r–p 00016000 08:01 2890473 /lib64/libnsl-2.13.so
7feb3d2be000-7feb3d2bf000 rw-p 00017000 08:01 2890473 /lib64/libnsl-2.13.so
7feb3d2bf000-7feb3d2c1000 rw-p 00000000 00:00 0
7feb3d2c1000-7feb3d2c9000 r-xp 00000000 08:01 2890474 /lib64/libnss_compat-2.13.so
7feb3d2c9000-7feb3d4c8000 —p 00008000 08:01 2890474 /lib64/libnss_compat-2.13.so
7feb3d4c8000-7feb3d4c9000 r–p 00007000 08:01 2890474 /lib64/libnss_compat-2.13.so
7feb3d4c9000-7feb3d4ca000 rw-p 00008000 08:01 2890474 /lib64/libnss_compat-2.13.so
7feb3d4ca000-7feb3d4d1000 r-xp 00000000 08:01 2890482 /lib64/librt-2.13.so
7feb3d4d1000-7feb3d6d1000 —p 00007000 08:01 2890482 /lib64/librt-2.13.so
7feb3d6d1000-7feb3d6d2000 r–p 00007000 08:01 2890482 /lib64/librt-2.13.so
7feb3d6d2000-7feb3d6d3000 rw-p 00008000 08:01 2890482 /lib64/librt-2.13.so
7feb3d70e000-7feb3d7f7000 r-xp 00000000 08:01 1086154 /usr/lib64/libasound.so.2.0.0
7feb3d7f7000-7feb3d9f7000 —p 000e9000 08:01 1086154 /usr/lib64/libasound.so.2.0.0
7feb3d9f7000-7feb3d9ff000 rw-p 000e9000 08:01 1086154 /usr/lib64/libasound.so.2.0.0
7feb3d9ff000-7feb3e7ed000 r–s 00000000 08:02 277138 /d1/.Other/d4/games/doom2.wad
7feb3e7ed000-7feb3e7f2000 r-xp 00000000 08:01 1085589 /usr/lib64/libXfixes.so.3.1.0
7feb3e7f2000-7feb3e9f1000 —p 00005000 08:01 1085589 /usr/lib64/libXfixes.so.3.1.0
7feb3e9f1000-7feb3e9f2000 rw-p 00004000 08:01 1085589 /usr/lib64/libXfixes.so.3.1.0
7feb3e9f2000-7feb3e9fb000 r-xp 00000000 08:01 1084860 /usr/lib64/libXcursor.so.1.0.2
7feb3e9fb000-7feb3ebfb000 —p 00009000 08:01 1084860 /usr/lib64/libXcursor.so.1.0.2
7feb3ebfb000-7feb3ebfc000 rw-p 00009000 08:01 1084860 /usr/lib64/libXcursor.so.1.0.2
7feb3ebfc000-7feb3ebfe000 r-xp 00000000 08:01 1051491 /usr/lib64/gconv/ISO8859-1.so
7feb3ebfe000-7feb3edfd000 —p 00002000 08:01 1051491 /usr/lib64/gconv/ISO8859-1.so
7feb3edfd000-7feb3edfe000 r–p 00001000 08:01 1051491 /usr/lib64/gconv/ISO8859-1.so
7feb3edfe000-7feb3edff000 rw-p 00002000 08:01 1051491 /usr/lib64/gconv/ISO8859-1.so
7feb3edff000-7feb3ee15000 r-xp 00000000 08:01 1091219 /usr/lib64/libz.so.1.2.5
7feb3ee15000-7feb3f014000 —p 00016000 08:01 1091219 /usr/lib64/libz.so.1.2.5
7feb3f014000-7feb3f015000 rw-p 00015000 08:01 1091219 /usr/lib64/libz.so.1.2.5
7feb3f015000-7feb3f02a000 r-xp 00000000 08:01 1074614 /usr/lib64/libgcc_s.so.1
7feb3f02a000-7feb3f229000 —p 00015000 08:01 1074614 /usr/lib64/libgcc_s.so.1
7feb3f229000-7feb3f22a000 rw-p 00014000 08:01 1074614 /usr/lib64/libgcc_s.so.1
7feb3f22a000-7feb3f310000 r-xp 00000000 08:01 1073950 /usr/lib64/libstdc++.so.6.0.14
7feb3f310000-7feb3f50f000 —p 000e6000 08:01 1073950 /usr/lib64/libstdc++.so.6.0.14
7feb3f50f000-7feb3f517000 r–p 000e5000 08:01 1073950 /usr/lib64/libstdc++.so.6.0.14
7feb3f517000-7feb3f519000 rw-p 000ed000 08:01 1073950 /usr/lib64/libstdc++.so.6.0.14
7feb3f519000-7feb3f52e000 rw-p 00000000 00:00 0
7feb3f52e000-7feb40927000 r-xp 00000000 08:01 1046619 /usr/lib64/libnvidia-glcore.so.260.19.36
7feb40927000-7feb40b27000 —p 013f9000 08:01 1046619 /usr/lib64/libnvidia-glcore.so.260.19.36
7feb40b27000-7feb41104000 rwxp 013f9000 08:01 1046619 /usr/lib64/libnvidia-glcore.so.260.19.36
7feb41104000-7feb4111a000 rwxp 00000000 00:00 0
7feb4111a000-7feb4111b000 r-xp 00000000 08:01 1710571 /usr/lib64/tls/libnvidia-tls.so.260.19.36
7feb4111b000-7feb4131b000 —p 00001000 08:01 1710571 /usr/lib64/tls/libnvidia-tls.so.260.19.36
7feb4131b000-7feb4131c000 rw-p 00001000 08:01 1710571 /usr/lib64/tls/libnvidia-tls.so.260.19.36
7feb4131c000-7feb41377000 r-xp 00000000 08:01 1046631 /usr/lib64/libvga.so.1.9.25
7feb41377000-7feb41577000 —p 0005b000 08:01 1046631 /usr/lib64/libvga.so.1.9.25
7feb41577000-7feb4157d000 rw-p 0005b000 08:01 1046631 /usr/lib64/libvga.so.1.9.25I_SignalHandler: Exiting on signal: signal 6

Comment from Lars
Posted: February 20, 2011 at 18:00

Many thanks for the KDE 4.6 packages!

If someone also has problems with the non working printer config dialog, there is an error in PyQt 4.8.2! A little typo prevents the start of the dialog.

This solved the problem for me -> http://permalink.gmane.org/gmane.comp.python.pyqt-pykde/21537

Comment from Mike
Posted: February 24, 2011 at 05:23

I installed kde 4.6, but now i have a question, is it ok to sync or “update” (whatever you wanna call it) to current having kde 4.6? i mean, slackware current has kde 4.5.5 wouldn’t there be any problems? like in the update, slackpkg trying to install kde 4.5.5 or something like that? please anybody help me.

Comment from Francisco Ambrozio
Posted: February 24, 2011 at 14:05

Mike, just blacklist the kde-4.6 packages (and its deps) and everything should be fine.

Write a comment