KDE 4.12.3 for Slackware-current (and 14.1) plus some goodies

Sticking nicely to the well-known KDE Release Schedule, here are packages for the latest and greatest KDE Software Compilation.

The new release 4.12.3 is a further step towards stabilizing the 4.12 platform and comes with updates to Plasma Workspaces, which brings that to version 4.11.7. Incidentally I also updated the Plasma Workspaces (aka kde-workplace)  in the KDE package set which I maintain for Slackware 14.1 (the KDE SC 4.11.5 release will keep getting long-term updates to kde-workspace until this summer)

Principally, I am targeting Slackware-current with my bleeding-edge packages for KDE. However – as was the case with the previous KDE release, there is not all that much divergence between the stable release (Slackware 14.1) and the development tree (Slackware-current). That is why I built my packages for KDE  4.12.3, on Slackware 14.1 for maximum compatibility. They work fine on both platforms.

What’s new in my KDE 4.12.3 packages?

Apart from all-new versions for the core applications, I also updated the oxygen-gtk2 and plasma-nm (and libnm-qt, libmm-qt) packages. I was unable to compile the latest oxygen-gtk3 release because Slackware’s GTK+-3 package is too old.

There is one interesting addition! There is a new package called kdeconnect-kde. Together with the kdeconnect-android app for your smartphone or tablet (no iPhone, surely you don’t own one??) it “fuses” your KDE desktop with your mobile device.

kdeconnect-settings

Prominent features of KDE Connect are: battery status display, clipboard share, notifications sync, multimedia remote control, and all of that over secured network connections. Don’t forget to add the new “KDE Connect” widget to your system tray.

kdeconnect-applet

How to upgrade to KDE 4.12.3 ?

You will find all the installation/upgrade instructions that you need in the accompanying README file. That README also contains basic information for KDE recompilation using the provided SlackBuild script.

You are strongly advised to read and follow these installation/upgrade instructions!

Where to find packages for KDE 4.12.3 ?

Download locations are listed below (you will find the sources in ./source/4.12.3/ and packages in /current/4.12.3/ subdirectories). Using a mirror is preferred because you get more bandwidth from a mirror and it’s friendlier to the owners of the master server!

Have fun! Eric

67 thoughts on “KDE 4.12.3 for Slackware-current (and 14.1) plus some goodies


  1. Hi Eric, thank you for the new release.
    Which package depends on LibRaw? I have LibRaw 0.16 installed and I would like to keep that, recompiling the kde packages against it, if it not ends up recompiling the whole suite 🙂 .

    Cheers


  2. Hi gianco

    LibRaw is used by libkdcraw. Perhaps a recompilation is not required, unless you encounter a real issue because of your newer LibRaw package.

    In case yu have to recompile that package, and you have downloaded all the sources, then this is the command to execute in the kde source directory and it will leave a new libkdcraw package in directory /tmp/kde-build/ :

    # ./KDE.SlackBuild kdegraphics:libkdcraw

    I will add an updated version of LibRaw to the future KDE 4.12.4.

    Eric



  3. Hi Alien BOB,

    thanks again for your packages. I also noticed that the new network management applet/widget got some updates — cool!

    lems


  4. Hi Eric, thank you for these updates!

    One question though, I see there’s no kwalllet package this time, has it been integrated into another package?



  5. Hi Ricardo

    You are right! The kwallet package was renamed to kwalletmanager in 4.12.3, how stupid is that!
    I will build a package for it today.

    Eric


  6. Hi Eric, the 4.12.3 packages are under current. I do not see one under 14.1 tree. If I update them from current tree on my 14.1 machine, will it break any dependencies?


  7. Hi Bob, thank you very much for your work!
    I ‘ve a dubt that perhaps you can help me to resolve.
    Every time I try to compile, with your script, a version of KDE I always obtain a kdm file that won’t start. But using your pre-compiled version of kde-workspace, that is the package that contains it, I finally get kde to work.
    Why my compiled version is build differently from yours?


  8. Hi chirpi

    Indeed, they are under ‘current’ because that is the Slackware release which I am targeting.
    However I have built these packages on Slackware 14.1 as a ‘courtesy service’ but you will not see them appear under ktown’s ‘14.1’ directory. If you want to use these packages in Slackware 14.1 you can do so without any concern for breaking stuff.

    Eric


  9. Hi Mirko

    I do not know your computer so I can make no educated guess about why you get a broken KDM when you compile it yourself. Do you actually download the complete source directory tree?

    I build my packages on a clean Slackware system with all the older KDE packages removed.

    Eric


  10. Thanks Eric!

    The old kwallet seems to be working fine with the new KDE but I’ll upgrade when the new package arrives.

    Cheers


  11. Hi Ricardo

    Actually, I had issues with the ownCloud client which suddenly refused to use the login credentlals stored in Kwallet. After upgrading to kwalletmanager my ownCloud client logs itself in automatically again.

    The packages are available on taper.alienbase.nl and alien.slackbook.org now. The other mirrors will sync within a day.

    Eric


  12. Mr. Eric Hameleers,

    I would like to thank you. Your new ktown release with KDEConnect, besides telegram-cli released last night (local time) are the two most beautiful packages I’ve seen on Slackware lately!

    Our mobile lives are vastly improved from now on thanks to you and all those wonderful devs behind KDE, telegram and tg-cli.

    Best wishes from Brazil.


  13. Thanks Eric for your reply. I compiled KDE from your complete source tree off the X environment, but I didn’t remove the old version before, just upgrade the packages already installed. All that using a Slackware current powered by an Intel I5 3550.
    I will retry this time without an installed version under the hood ok.


  14. Hi Eric,

    I would like to thank you for this new release of KDE. It works fine on my laptop (KDE current with multilib). I am only having difficulties to find the KDE connect widget. Am I blind?

    Cheers, thanks and all the best from Berlin

    Step


  15. Hello Mr. Heric,
    I wold like to thank you for your work on our preferred distro.
    I’ve just installed this version of KDE (i usually keep all in current under my Slackware) going from 4.12.1 to 4.12.3 I’ve noticed that Dolphin became very slow on opening.
    I tried to launch it from terminal and have this results :

    Fontconfig warning: “/etc/fonts/conf.d/50-user.conf”, line 14: reading configurations from ~/.fonts.conf is deprecated.
    Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
    Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
    QPixmap::scaled: Pixmap is a null pixmap
    dolphin(13131) KSambaSharePrivate::testparmParamValue: We got some errors while running testparm “Load smb config files from /etc/samba/smb.conf
    Ignoring unknown parameter “acl compatibility”
    Loaded services file OK.
    WARNING: ‘workgroup’ and ‘netbios name’ must differ.
    WARNING: You have some share names that are longer than 12 characters.
    These may not be accessible to some older clients.
    (Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)

    dolphin(13131)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed: “Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.”

    May depend on what? The previous version worked perfectly.

    Thanks in advance for the reply.


  16. Hello,
    I’ve resolved from my own. On a Debian form I’ve found that the problem mostly is caused by some old KDE configuration files.

    I’ve removed those files from ~/.kde/share/config :

    kwin.eventsrc
    kwinkeramikrc
    kwinrc
    kwinrulesrc

    After this, I’ve restarted KDE and the behavior is unchanged except for the virtual desktops, for which I had to reset it to the old number (I’ve six virtual desktops).
    Now Dolphin starts fast and the other software seems to work fair.
    Thank you for your great work!


  17. Hello, Stephan. I can help you on KDE Connect widget matter, as I found myself lost on that one to for a few minutes before I remember how to get it done (it’s a very unusual task for me).

    To get it temporarily only, you can open a windowed application by hitting ALT+F2 to open ‘run command’ dialog, search for ‘connect’ and it will show up as the first result.

    For a permanent wiget in one of your panels, click on the little gold thing icon (what is that?!?) and choose ‘Add widgets…’ From the widget chooser panel, scroll to KDE Connect or type ‘connect’ in the search box. Once you get to the widget icon, just double click and it should appear in the panel you’re choose to set. In this mode you can also reposition it at your will.

    Have fun!


  18. Hi Eric, thanks for compiling the new releases. I especially like that I can now use more online services on Marble than before.

    The one problem was that Kajongg failed to install an executable even with zope-interface and python-twisted installed. However, I was able to get Kajongg to install properly and run by building from source, after all the dependencies were installed.


  19. Thanks for the update.

    1 minor thing. This was true for the default package in 14.1

    When you run KGoldrunner it starts but brings up this warning:

    “Warning this copy of KGoldrunner has no sound. This is because no development vesions of OpenAL and SNDFile were present when it was compiled and built.”


  20. Thanks Deny,

    since I had tried these ways already and didn’t find the connect widget or program I will now see if I am missing a package in KDE. This is pretty well possible since I upgraded with slackpkg+ from the Ktown repository and didn’t read the README because it normally works fine (-: . However it might does not work for new packages added to KDE. I will keep you posted.



  21. Eric,

    I had some issues with file browsing plugin of KDE Connect and contacted its developer, Albert (a very responsive guy I should say), and it point that maybe the kio slave is not packaged on your ktown distribution and this could be related to the issue.

    You can take a look om this chat here:

    http://albertvaka.wordpress.com/2013/08/05/introducing-kde-connect/#comment-928

    As I said there, I’ve searched ktown latest repository for current branch and I’ve found no mention about a kio package there besides audiocd, kdesdk-kioslaves and kio-mtp.

    I asked him to point me out where we can find sources for this kio. As soon as he reply, should I let you know so you can include it to ktown?



  22. Stephan,

    If you want to also install packages that are new in the ktown repository (not just the upgraded ones) then you can try this sequence (assuming you named the repository “ktown” in slackpkgplus.conf):

    # slackpkg update
    # slackpkg install ktown
    # slackpkg upgrade-all

    The “slackpkg install ktown” command will install every package in that “ktown” repository which you did not yet install. That includes all the kdei packages (language packs) so you will have to de-select those if you don’t want them.

    Eric


  23. I had to manually install the new kde packages. It seems that slackpkg+ does not do this automatically which is good. Slackpkg+ seems to upgrade only packages which are already installed on your system and I really like this. After manually upgrading the missing KDE packages I have the KDE connect widget but it does not work with my Galaxy SIII together with my wireless settings. I will now wait for Eric’s response to Deny’s comments. Thanks guys. I really appreciate the friendly communication here.



  24. Thank you very much, Eric! I managed to compile it from source, although I couldn’t managed to install yet in the proper way. Anyway, your packages are greatly appreciated!


  25. Sorry Eric. I didn’t read your response before I replied )-: ! However, I downloaded all your KDE packages and installed all new packages (upgradepkg –install-new x86_64/deps/*.t?z and upgradepkg –install-new x86_64/kde/*.t?z). That resolved the issue for me without installing the kdei packages. Again thanks for all the help one receives here. That is one thing other Linux repos can not and maybe never will be able to provide. It is us and even more you (the experienced Slackers) provide. Thanks. I hope that I can provide some help as well now and then.


  26. Eric, just to let you know that I managed to install kdeconnect-kde that I compiled myself from the latest git repo commit (3fff0a33 at this time) and the kio slave missing for kdeconnect:// protocol works for me.

    There are still a crash on kwin when activating the underlying fuse/sshfs, but after kwin recovers itself, all works fine and I can see ‘All Files’ and ‘Camera pictures’ directories after click on the device icon in the Dolphin’s location bar.


  27. Hi Deny

    In the “stable” 0.5 tarball, the kio directory had been commented out, and that was why it was not compiled.
    I have downloaded the latest update to the “0.5” tag in the repository where they re-enabled the kioslave again, together with some other fixes. I’ll see what that brings.

    Eric


  28. Well actually they did not even enable the kioslave in that update… I should perhaps just bite the bullet and use the latest git snapshot.

    Eric


  29. Oh, Eric! Now I see what Albert meant by this statement:

    “We released a version without the KIO for Kubuntu 14.04, but then you should not have the file browsing plugin either.”

    Well, I did bit the bullet. #wfm 😉


  30. I tried compiling libkfbapi and libkgapi which are available in the KDE sources and adds Facebook and Google integration abilities to KDE. However after installing them it doesn’t seem to have added them..

    Is there something else that I am missing or doing wrong?


  31. Hi Dan

    I can not tell you. I did not add those as packages, so I have no idea what their effect will be.
    However, for libkfbapi and libkgapi to have any effect, you need to recompile kdepim-runtime in their presence:

    * LibKGAPI2 (required version >= 1.9.81) , KDE-based library for accessing various Google services ,
    LibKGAPI is required to build Akonadi resources to access Google Contacts, Calendars and Tasks
    * LibKFbAPI (required version >= 1.0) , A library to access Facebook services ,
    LibKFbAPI is required to build Akonadi resources to access Facebook’s contacts, events, notes and posts

    Eric


  32. Deny,

    I built a newer version of kdeconnect-kde with the kioslave enabled. But indeed it crashes the KDE desktop the first time you try to open an Android device’s filesystem browser. Which is ugly and I understand why the developers disabled this for Kubuntu 14.04.
    The second time, I get a report that my Android device can not be reached… probably because it is running an old Android version (2.3).
    I am in doubt whether I should release this new package, because of the bad way it crashes your desktop.

    Eric


  33. Eric,

    Yeah. I feel your pain. For a public release, I stick on your side and don’t release a package with this behavior. Although I have managed to compile, install and run this unstable version here, others out there could get pretty scared when they KWin get vanished for a while (which makes me remember how Windows Explorer crashes).

    I think it would be nice from our side to just wait for the KDE Connect devs to fix this issue and them release a clean, non crashing package. Such a great project and the quality of your own work just don’t need this scratch.

    What about you?

    Deny


  34. Eric,

    I forgot to mention that there are issues with Android 2.3 and even 4.3. Mine is 4.4 (CyanogenMod 11), so it works just fine. KDE Connect devs are working on that too.

    Deny



  35. Thanks Eric.. I’ll take a look into it.

    I think it would be nice to include those libraries (libkfbapi and libkgapi) in future releases.. they do work nicely or other distros where I have set them up for people. 🙂



  36. Eric,

    just recompiled kdepim-runtime and it’s worked. It detected the libraries and I can now integrate my Google and Facebook accounts into KDE.

    Thanks.
    🙂


  37. Hi Eric, just to close the topic relatively to corrupted kdm, I ‘ve tried to compile source on my notebook but removing old version before.
    Well it seems that it worked, now environment loads correctly.
    Thanks once again.



  38. Solarized themes in latest konsole doens’t show directory colors, others themes do. I wasn’t the case with 4.11.4.



  39. Hi!
    It would be nice to hear some advice how to get usb device auto-mount back – after upgrade to 4.12.3 from 4.11.5 I have to manually choose what to do with the attached device. The fact that devices now are mounting under /run/media/user I already found.


  40. Hi Janis

    Yes, the new mount location is /run/media/$USERNAME which allows for better data privacy when more people than just one are working on the same computer.

    As for automounting removable storage devices in KDE, that is a feature I always turn off as fast as I can, whenever I find it enabled… but if you want it enabled, just go into the “Device Notifier Settings” by right-clicking on its icon in the system tray, and then look at the item “Removable Devices”. You will find the checkbox to “Enable automatic mounting of removable media”, along with a set of more specific tuning parameters.

    Eric


  41. Hi , i found a big bug in all kde 4.11 & 4.12 branches

    Is a KDE bug , i can reproduce in kubuntu , slack , and other distros.

    What bug ?

    After copy a folder whit big number of files and subfolders to desktop andr “delete” , the porcess delete files only 1 to 1 ( slow ,very slow )

    How reproduce ?

    1 – put plasma to “folder view”
    2 – go dolphin and activate “delete” ,service
    3 – copy a big folder in desktop …like /usr
    4 – try delete whit dolphin service
    5 – see in the taskbar ..process are delting files 1 to 1

    kde 4.10.X or minor woks perfectly , is not compilation problem , is not slackware problem … ITS KDE PROBLEM.

    As i can say i can reproduce this , in other distros, like kubuntu.

    When recompile a kernel and disable “SMP” , the bug dissapears.



  42. Pingback: strace dolphin recv( )

  43. Pingback: Alien Pastures » KDE SC 4.12.4 for Slackware 14.1 and -current


  44. “if you want [automount] enabled, just go into the “Device Notifier Settings” by right-clicking on its icon in the system tray, and then look at the item “Removable Devices”. You will find the checkbox to “Enable automatic mounting of removable media”, along with a set of more specific tuning parameters.”

    automount of removable devices is working out-of-the-box with kde 4.11, kde 4.12 goes no futher than offering mount methods. I could try to live with that but I do not want to see any file manager opening anything on desktop. All I need is to get the device mounted in file system, thats all. (like kde 4.11 is doing with just a slight configuration) May be it is back in 4.13. or 4.14, but none of these are built for Slack-14.1



  45. Can’t connect to KDE Connect v.0.7.3.4 Android app any more. Anybody have it working?
    Eric, could you update kdeconnect-kde package – maybe, that is the reason?


  46. I have KDE Connect 0.7.3.4 on my Android phone and it is currently talking to the Slackware-current box with kdeconnect-kde 0.7.3.

    Are you on an older version of KDE and/or an older version of kdeconnect-kde? I am running KDE 4.14.3. The kdeconnect-kde 0.7.3 is the most recent version available.


  47. Hi Eric, sorry – I missed your message.
    I also running KDE 4.14.3 with kdeconnect-kde 0.7.3, but on Slackware 14.1.
    Can’t see any device not in kdeconnect desktop widget nor in the Android app. It worked earlier though. Odd.. Maybe I should test it on clean install on Virtual machine..


  48. Here is more info:
    bam@darkstar:~$ kdeconnect-cli -l
    kdeconnect-cli(6769)/kdeconnect DevicesModel::refreshDeviceList: dbus interface not valid
    0 devices found


  49. Farther info:
    looks like ‘kdeconnectd’ daemon was not started. When I start it manually, kdeconnect works OK. Any thoughts why the daemon not starts automatically?


  50. Oh, I’m sorry, my fault – I suppose I have upgraded but didn’t restart the system ) After restart, kdeconnect works perfectly! Thank you for paying attention to this, Eric


  51. You upgraded your computer five weeks ago? You did not tell that at first; you only stated that you could not connect to your phone anymore.
    Did you upgrade without exiting your X session?
    Anyway, good to hear that you found your error.


    1. I don’t remember when I upgraded, maybe it was when you rollout new KDE packages 😉 I just suppose that was the reason of the problem. And yes, to be honest – I never exit X session after upgrade, and things go pretty well usually. Until this moment.. )




Leave a Reply to Abraham Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.